RESOLVED FIXED Bug 111923
Don't create multiple user gesture indicators when forwarding events to sub frames
https://bugs.webkit.org/show_bug.cgi?id=111923
Summary Don't create multiple user gesture indicators when forwarding events to sub f...
jochen
Reported 2013-03-09 11:14:33 PST
Don't create multiple user gesture indicators when forwarding events to sub frames
Attachments
Patch (7.84 KB, patch)
2013-03-09 11:16 PST, jochen
no flags
Patch (10.31 KB, patch)
2013-03-11 15:29 PDT, jochen
no flags
jochen
Comment 1 2013-03-09 11:16:55 PST
Adam Barth
Comment 2 2013-03-09 11:21:45 PST
Comment on attachment 192347 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=192347&action=review > Source/WebCore/page/EventHandler.cpp:3169 > + OwnPtr<UserGestureIndicator> gestureIndicator; > + > + if (!UserGestureIndicator::processingUserGesture()) > + gestureIndicator = adoptPtr(new UserGestureIndicator(DefinitelyProcessingUserGesture)); Why doesn't UserGestureIndicator do this work for us? If we're already processing a user gesture, perhaps the UserGestureIndicator shouldn't bump the count in the token... Maybe that should be an option in the constructor?
jochen
Comment 3 2013-03-09 11:35:41 PST
(In reply to comment #2) > (From update of attachment 192347 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=192347&action=review > > > Source/WebCore/page/EventHandler.cpp:3169 > > + OwnPtr<UserGestureIndicator> gestureIndicator; > > + > > + if (!UserGestureIndicator::processingUserGesture()) > > + gestureIndicator = adoptPtr(new UserGestureIndicator(DefinitelyProcessingUserGesture)); > > Why doesn't UserGestureIndicator do this work for us? If we're already processing a user gesture, perhaps the UserGestureIndicator shouldn't bump the count in the token... Maybe that should be an option in the constructor? That's a good question. I guess that doing this by default won't work, e.g. when we run a nested message loop with a indicator on the stack during a showModalDialog() call. I need to think of a good name for an additional enum
jochen
Comment 4 2013-03-11 15:29:24 PDT
jochen
Comment 5 2013-03-11 15:30:32 PDT
As soon as bug 111959 is resolved, this patch will apply
Adam Barth
Comment 6 2013-03-11 15:42:41 PDT
Comment on attachment 192575 [details] Patch Thanks, this is much better.
WebKit Review Bot
Comment 7 2013-03-11 22:47:33 PDT
Comment on attachment 192575 [details] Patch Clearing flags on attachment: 192575 Committed r145481: <http://trac.webkit.org/changeset/145481>
WebKit Review Bot
Comment 8 2013-03-11 22:47:36 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.