Bug 109136 - REGRESSION (r140778): Calendar Picker doesn't open when the element has the required attribute
Summary: REGRESSION (r140778): Calendar Picker doesn't open when the element has the r...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Keishi Hattori
URL:
Keywords:
: 110010 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-06 22:36 PST by Keishi Hattori
Modified: 2013-02-21 16:44 PST (History)
4 users (show)

See Also:


Attachments
Patch (4.61 KB, patch)
2013-02-06 22:59 PST, Keishi Hattori
no flags Details | Formatted Diff | Diff
Patch (58.72 KB, patch)
2013-02-07 01:52 PST, Keishi Hattori
no flags Details | Formatted Diff | Diff
Patch (58.71 KB, patch)
2013-02-07 02:27 PST, Keishi Hattori
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keishi Hattori 2013-02-06 22:36:25 PST
CalendarPicker.fixWindowSize is broken.
Comment 1 Keishi Hattori 2013-02-06 22:59:30 PST
Created attachment 186994 [details]
Patch
Comment 2 Kent Tamura 2013-02-06 23:10:58 PST
Comment on attachment 186994 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=186994&action=review

> Source/WebCore/ChangeLog:13
> +        No new tests. Covered by existing calendar picker appearance tests.

Really? Do we have a calendar picker test with <input type=date required>?
Comment 3 Keishi Hattori 2013-02-07 01:52:20 PST
Created attachment 187025 [details]
Patch
Comment 4 Kent Tamura 2013-02-07 01:57:45 PST
Comment on attachment 187025 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=187025&action=review

> LayoutTests/platform/chromium/TestExpectations:4252
> +webkit.org/b/107508 platform/chromium/fast/forms/calendar-picker/calendar-picker-appearance-required.html [ ImageOnlyFailure Pass ]
> +webkit.org/b/107508 platform/chromium/fast/forms/calendar-picker/calendar-picker-appearance-required-ar.html [ ImageOnlyFailure Pass ]

Wrong bug number.  They should be 109136.
Comment 5 Keishi Hattori 2013-02-07 02:27:56 PST
Created attachment 187028 [details]
Patch
Comment 6 WebKit Review Bot 2013-02-07 06:43:56 PST
Comment on attachment 187028 [details]
Patch

Clearing flags on attachment: 187028

Committed r142111: <http://trac.webkit.org/changeset/142111>
Comment 7 WebKit Review Bot 2013-02-07 06:44:00 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 Kent Tamura 2013-02-07 15:53:32 PST
https://bugs.webkit.org/show_bug.cgi?id=108055#c10

Comment #10 From Gavin Peters 2013-02-07 08:39:06 PST (-) [reply]
Reverted r142111 for reason:

win7 bot didn't display arabic

Committed r142130: <http://trac.webkit.org/changeset/142130>

Comment #11 From Gavin Peters 2013-02-07 09:12:40 PST (-) [reply]
The win7 calendar lacked Arabic: http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=platform%2Fchromium%2Ffast%2Fforms%2Fcalendar-picker%2Fcalendar-picker-appearance-required-ar.html , so I wan't comfortable rebaselining this myself.
Comment 9 Kent Tamura 2013-02-07 15:58:10 PST
Comment on attachment 187028 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=187028&action=review

> LayoutTests/ChangeLog:4
> +        https://bugs.webkit.org/show_bug.cgi?id=108055

wrong bug number

> LayoutTests/platform/chromium/TestExpectations:4252
> +webkit.org/b/109136 platform/chromium/fast/forms/calendar-picker/calendar-picker-appearance-required.html [ ImageOnlyFailure Pass ]
> +webkit.org/b/109136 platform/chromium/fast/forms/calendar-picker/calendar-picker-appearance-required-ar.html [ ImageOnlyFailure Pass ]

Need to add "Missing"

> LayoutTests/platform/chromium/fast/forms/calendar-picker/calendar-picker-appearance-required-ar.html:14
> +<input type=date id=date value="1800-12-31" required lang="ar_AE">

I think ar_AE is wrong.  It should be ar-AE.
Comment 10 Kent Tamura 2013-02-07 16:08:41 PST
Committed r142198: <http://trac.webkit.org/changeset/142198>
Comment 11 Kent Tamura 2013-02-07 17:57:40 PST
(In reply to comment #10)
> Committed r142198: <http://trac.webkit.org/changeset/142198>

I verified this worked on Windows 7 buildbot.
Comment 12 Keishi Hattori 2013-02-07 17:59:14 PST
(In reply to comment #11)
> (In reply to comment #10)
> > Committed r142198: <http://trac.webkit.org/changeset/142198>
> 
> I verified this worked on Windows 7 buildbot.

I'm sorry. Thanks!
Comment 13 Kent Tamura 2013-02-21 16:44:40 PST
*** Bug 110010 has been marked as a duplicate of this bug. ***