Bug 108767 - dataTransfer.types should be DOMStringList instead of Array
Summary: dataTransfer.types should be DOMStringList instead of Array
Status: RESOLVED DUPLICATE of bug 30416
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-03 03:11 PST by danya.postfactum
Modified: 2013-02-04 12:54 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description danya.postfactum 2013-02-03 03:11:56 PST
According to the http://dev.w3.org/html5/spec-preview/dnd.html#dom-datatransfer-types spec the current types implementation is wrong.
My app need to accept any data except files, so I use "if (!dataTransfer.types.contains('Files')) {..}" and it does not work (
Comment 1 Alexey Proskuryakov 2013-02-04 12:54:15 PST

*** This bug has been marked as a duplicate of bug 30416 ***