Bug 107922 - Call FrameView::contentsResized() when setting fixed layout size
Summary: Call FrameView::contentsResized() when setting fixed layout size
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexandre Elias
URL:
Keywords:
: 107206 (view as bug list)
Depends on: 108120
Blocks: 108446
  Show dependency treegraph
 
Reported: 2013-01-24 23:34 PST by Alexandre Elias
Modified: 2013-01-31 11:27 PST (History)
4 users (show)

See Also:


Attachments
Patch (7.05 KB, patch)
2013-01-24 23:40 PST, Alexandre Elias
no flags Details | Formatted Diff | Diff
Patch (7.05 KB, patch)
2013-01-25 13:59 PST, Alexandre Elias
no flags Details | Formatted Diff | Diff
Patch (5.54 KB, patch)
2013-01-31 01:53 PST, Alexandre Elias
no flags Details | Formatted Diff | Diff
Patch (20.45 KB, patch)
2013-01-31 02:19 PST, Alexandre Elias
no flags Details | Formatted Diff | Diff
Patch for landing (20.45 KB, patch)
2013-01-31 02:48 PST, Alexandre Elias
no flags Details | Formatted Diff | Diff
Patch for landing (20.45 KB, patch)
2013-01-31 10:37 PST, Alexandre Elias
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Elias 2013-01-24 23:34:53 PST
Call FrameView::contentResized() when setting fixed layout size
Comment 1 Alexandre Elias 2013-01-24 23:40:33 PST
Created attachment 184680 [details]
Patch
Comment 2 Alexandre Elias 2013-01-24 23:45:22 PST
*** Bug 107206 has been marked as a duplicate of this bug. ***
Comment 3 Adam Barth 2013-01-25 09:23:05 PST
Who is the right person to review this change?
Comment 4 James Robinson 2013-01-25 10:29:29 PST
Comment on attachment 184680 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=184680&action=review

R=me. The WebCore changes seem quite reasonable.

> Source/WebCore/platform/ScrollView.cpp:280
> +    if (useFixedLayout())

nit: use m_useFixedLayout in ScrollView.cpp, like the rest of the file does
Comment 5 Alexandre Elias 2013-01-25 13:59:21 PST
Created attachment 184807 [details]
Patch

Fix nit
Comment 6 WebKit Review Bot 2013-01-25 15:03:56 PST
Comment on attachment 184807 [details]
Patch

Clearing flags on attachment: 184807

Committed r140869: <http://trac.webkit.org/changeset/140869>
Comment 7 WebKit Review Bot 2013-01-25 15:04:00 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 WebKit Review Bot 2013-01-28 15:02:17 PST
Re-opened since this is blocked by bug 108120
Comment 9 Alexandre Elias 2013-01-31 01:53:57 PST
Created attachment 185718 [details]
Patch
Comment 10 Alexandre Elias 2013-01-31 02:19:17 PST
Created attachment 185724 [details]
Patch
Comment 11 Alexandre Elias 2013-01-31 02:46:41 PST
Relanding as WebCore changes are identical.
Comment 12 Alexandre Elias 2013-01-31 02:48:20 PST
Created attachment 185728 [details]
Patch for landing
Comment 13 WebKit Review Bot 2013-01-31 04:11:35 PST
Comment on attachment 185728 [details]
Patch for landing

Rejecting attachment 185728 [details] from commit-queue.

New failing tests:
media/track/track-cues-enter-exit.html
media/track/track-cues-cuechange.html
Full output: http://queues.webkit.org/results/16280133
Comment 14 Alexandre Elias 2013-01-31 10:37:18 PST
Created attachment 185808 [details]
Patch for landing
Comment 15 WebKit Review Bot 2013-01-31 11:27:15 PST
Comment on attachment 185808 [details]
Patch for landing

Clearing flags on attachment: 185808

Committed r141450: <http://trac.webkit.org/changeset/141450>
Comment 16 WebKit Review Bot 2013-01-31 11:27:19 PST
All reviewed patches have been landed.  Closing bug.