Bug 107913 - REGRESSION(r140554): Crashing table-section-overflow-clip-crash.html (Requested by keishi on #webkit).
Summary: REGRESSION(r140554): Crashing table-section-overflow-clip-crash.html (Request...
Status: RESOLVED DUPLICATE of bug 107958
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 107613
  Show dependency treegraph
 
Reported: 2013-01-24 21:59 PST by WebKit Review Bot
Modified: 2013-01-25 09:54 PST (History)
3 users (show)

See Also:


Attachments
ROLLOUT of r140554 (6.03 KB, patch)
2013-01-24 21:59 PST, WebKit Review Bot
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2013-01-24 21:59:25 PST
http://trac.webkit.org/changeset/140554 broke the build:
Crashing table-section-overflow-clip-crash.html (Requested by keishi on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2013-01-24 21:59:53 PST
Created attachment 184661 [details]
ROLLOUT of r140554

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Keishi Hattori 2013-01-24 22:01:12 PST
crash log for DumpRenderTree (pid 3560):
STDOUT: <empty>
STDERR: ASSERTION FAILED: !object->isSetNeedsLayoutForbidden()
STDERR: ../../third_party/WebKit/Source/WebCore/rendering/RenderObject.cpp(682) : void WebCore::RenderObject::markContainingBlocksForLayout(bool, WebCore::RenderObject *)
STDERR: 1   0x366a3969 WebCore::RenderObject::markContainingBlocksForLayout(bool, WebCore::RenderObject*)
STDERR: 2   0x352e05a3 WebCore::RenderObject::setNeedsLayout(bool, WebCore::MarkingBehavior)
STDERR: 3   0x35268d16 WebCore::RenderObject::setNeedsLayoutAndPrefWidthsRecalc()
STDERR: 4   0x3657f875 WebCore::RenderCounter::invalidate()
STDERR: 5   0x36403c24 WebCore::CounterNode::resetRenderers()
STDERR: 6   0x36403ba6 WebCore::CounterNode::~CounterNode()
STDERR: 7   0x3640399b WebCore::CounterNode::~CounterNode()
STDERR: 8   0x36589909 WTF::RefCounted<WebCore::CounterNode>::deref()
STDERR: 9   0x36589888 void WTF::derefIfNotNull<WebCore::CounterNode>(WebCore::CounterNode*)
STDERR: 10  0x3658981d WTF::RefPtr<WebCore::CounterNode>::~RefPtr()
STDERR: 11  0x3658368b WTF::RefPtr<WebCore::CounterNode>::~RefPtr()
STDERR: 12  0x36584606 WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >::~KeyValuePair()
STDERR: 13  0x365845ab WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >::~KeyValuePair()
STDERR: 14  0x36583f2b WTF::HashTable<WTF::AtomicString, WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >, WTF::KeyValuePairKeyExtractor<WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> > >, WTF::AtomicStringHash, WTF::HashMapValueTraits<WTF::HashTraits<WTF::AtomicString>, WTF::HashTraits<WTF::RefPtr<WebCore::CounterNode> > >, WTF::HashTraits<WTF::AtomicString> >::deleteBucket(WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >&)
STDERR: 15  0x36583e98 WTF::HashTable<WTF::AtomicString, WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >, WTF::KeyValuePairKeyExtractor<WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> > >, WTF::AtomicStringHash, WTF::HashMapValueTraits<WTF::HashTraits<WTF::AtomicString>, WTF::HashTraits<WTF::RefPtr<WebCore::CounterNode> > >, WTF::HashTraits<WTF::AtomicString> >::remove(WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >*)
STDERR: 16  0x36583d67 WTF::HashTable<WTF::AtomicString, WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >, WTF::KeyValuePairKeyExtractor<WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> > >, WTF::AtomicStringHash, WTF::HashMapValueTraits<WTF::HashTraits<WTF::AtomicString>, WTF::HashTraits<WTF::RefPtr<WebCore::CounterNode> > >, WTF::HashTraits<WTF::AtomicString> >::removeAndInvalidateWithoutEntryConsistencyCheck(WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >*)
STDERR: 17  0x365839b8 WTF::HashTable<WTF::AtomicString, WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >, WTF::KeyValuePairKeyExtractor<WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> > >, WTF::AtomicStringHash, WTF::HashMapValueTraits<WTF::HashTraits<WTF::AtomicString>, WTF::HashTraits<WTF::RefPtr<WebCore::CounterNode> > >, WTF::HashTraits<WTF::AtomicString> >::removeWithoutEntryConsistencyCheck(WTF::HashTableIterator<WTF::AtomicString, WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >, WTF::KeyValuePairKeyExtractor<WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> > >, WTF::AtomicStringHash, WTF::HashMapValueTraits<WTF::HashTraits<WTF::AtomicString>, WTF::HashTraits<WTF::RefPtr<WebCore::CounterNode> > >, WTF::HashTraits<WTF::AtomicString> >)
STDERR: 18  0x3658342d WTF::HashMap<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode>, WTF::AtomicStringHash, WTF::HashTraits<WTF::AtomicString>, WTF::HashTraits<WTF::RefPtr<WebCore::CounterNode> > >::remove(WTF::HashTableIteratorAdapter<WTF::HashTable<WTF::AtomicString, WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> >, WTF::KeyValuePairKeyExtractor<WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> > >, WTF::AtomicStringHash, WTF::HashMapValueTraits<WTF::HashTraits<WTF::AtomicString>, WTF::HashTraits<WTF::RefPtr<WebCore::CounterNode> > >, WTF::HashTraits<WTF::AtomicString> >, WTF::KeyValuePair<WTF::AtomicString, WTF::RefPtr<WebCore::CounterNode> > >)
STDERR: 19  0x3657ff5d WebCore::RenderCounter::destroyCounterNode(WebCore::RenderObject*, WTF::AtomicString const&)
STDERR: 20  0x364048ff WebCore::CounterNode::insertAfter(WebCore::CounterNode*, WebCore::CounterNode*, WTF::AtomicString const&)
STDERR: 21  0x3657f28a WebCore::makeCounterNode(WebCore::RenderObject*, WTF::AtomicString const&, bool)
STDERR: 22  0x3657ed1d WebCore::RenderCounter::originalText() const
STDERR: 23  0x3657f748 WebCore::RenderCounter::computePreferredLogicalWidths(float)
STDERR: 24  0x367472e6 WebCore::RenderText::trimmedPrefWidths(float, float&, bool&, float&, bool&, bool&, bool&, float&, float&, float&, float&, bool&)
STDERR: 25  0x364972b5 WebCore::RenderBlock::computeInlinePreferredLogicalWidths()
STDERR: 26  0x36495f45 WebCore::RenderBlock::computePreferredLogicalWidths()
STDERR: 27  0x3652503a WebCore::RenderBox::minPreferredLogicalWidth() const
STDERR: 28  0x36497bd6 WebCore::RenderBlock::computeBlockPreferredLogicalWidths()
STDERR: 29  0x36495f58 WebCore::RenderBlock::computePreferredLogicalWidths()
STDERR: 30  0x3652503a WebCore::RenderBox::minPreferredLogicalWidth() const
STDERR: 31  0x36497bd6 WebCore::RenderBlock::computeBlockPreferredLogicalWidths()
STDERR: Received signal 11 SEGV_MAPERR 0000bbadbeef
STDERR:  [0x000032e75a1f]
STDERR:  [0x000032e759bb]
STDERR:  [0x000032e7564b]
STDERR:  [0x000097bb505b]
STDERR:  [0x0000ffffffff]
STDERR:  [0x0000352e05a3]
STDERR:  [0x000035268d16]
STDERR:  [0x00003657f875]
STDERR:  [0x000036403c24]
STDERR:  [0x000036403ba6]
STDERR:  [0x00003640399b]
STDERR:  [0x000036589909]
STDERR:  [0x000036589888]
STDERR:  [0x00003658981d]
STDERR:  [0x00003658368b]
STDERR:  [0x000036584606]
STDERR:  [0x0000365845ab]
STDERR:  [0x000036583f2b]
STDERR:  [0x000036583e98]
STDERR:  [0x000036583d67]
STDERR:  [0x0000365839b8]
STDERR:  [0x00003658342d]
STDERR:  [0x00003657ff5d]
STDERR:  [0x0000364048ff]
STDERR:  [0x00003657f28a]
STDERR:  [0x00003657ed1d]
STDERR:  [0x00003657f748]
STDERR:  [0x0000367472e6]
STDERR:  [0x0000364972b5]
STDERR:  [0x000036495f45]
STDERR:  [0x00003652503a]
STDERR:  [0x000036497bd6]
STDERR:  [0x000036495f58]
STDERR:  [0x00003652503a]
STDERR:  [0x000036497bd6]
STDERR:  [0x000036495f58]
STDERR:  [0x00003652503a]
STDERR:  [0x000036497bd6]
STDERR:  [0x000036495f58]
STDERR:  [0x00003652503a]
STDERR:  [0x000036497bd6]
STDERR:  [0x000036495f58]
STDERR:  [0x00003652503a]
STDERR:  [0x000036497bd6]
STDERR:  [0x000036495f58]
STDERR:  [0x00003652503a]
STDERR:  [0x00003466bad6]
STDERR:  [0x00002f210360]
STDERR:  [0x000034744bee]
STDERR:  [0x000034573faa]
STDERR:  [0x00003757a30f]
STDERR:  [0x000035249def]
STDERR:  [0x000035249f1a]
STDERR:  [0x000035329908]
STDERR:  [0x000035abe472]
STDERR:  [0x00003021da90]
STDERR:  [0x00003021d589]
STDERR:  [0x00003015f6a6]
STDERR:  [0x0000301665c4]
STDERR:  [0x00004230a716]
STDERR: ax: bbadbeef, bx: 30203601, cx: 3020363a, dx: 3020363a
STDERR: di: 37aee01f, si: 37aedfa8, bp: bfff9718, sp: bfff9690, ss: 23, flags: 10286
STDERR: ip: 366a3973, cs: 1b, ds: 23, es: 23, fs: 0, gs: f
Comment 3 WebKit Review Bot 2013-01-24 22:06:16 PST
Comment on attachment 184661 [details]
ROLLOUT of r140554

Rejecting attachment 184661 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=gce-cq-02', 'apply-attachment', '--no-update', '--non-interactive', 184661, '--port=chromium-xvfb']" exit_code: 2 cwd: /mnt/git/webkit-commit-queue

Last 500 characters of output:
m patch file(s).
patch: **** Can't create file /tmp/ppqaxh6N : No space left on device
patch: **** Can't create file /tmp/ppMr6q2O : No space left on device
patch: **** Can't create file /tmp/ppPFFXEO : No space left on device
patch: **** Can't create file /tmp/ppla8aSO : No space left on device
patch: **** Can't create file /tmp/ppcQ0hhN : No space left on device

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', '--force']" exit_code: 2 cwd: /mnt/git/webkit-commit-queue

Full output: http://queues.webkit.org/results/16116141
Comment 4 Ojan Vafai 2013-01-25 09:49:22 PST
I have a fix for this coming shortly. Strangely, the assert only seems to hit on Chromium Mac.
Comment 5 Ojan Vafai 2013-01-25 09:54:09 PST

*** This bug has been marked as a duplicate of bug 107958 ***