Bug 107029 - [Qt] QtWebKit-based browsers crash with QtWebKit 2.3
Summary: [Qt] QtWebKit-based browsers crash with QtWebKit 2.3
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P3 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: QtWebkit23
  Show dependency treegraph
 
Reported: 2013-01-16 10:02 PST by Filip Brcic
Modified: 2013-02-05 06:00 PST (History)
3 users (show)

See Also:


Attachments
Output from the crashing rekonq (3.37 KB, text/plain)
2013-01-16 10:02 PST, Filip Brcic
no flags Details
Output from the crashing arora (2.57 KB, text/plain)
2013-01-16 10:03 PST, Filip Brcic
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Brcic 2013-01-16 10:02:33 PST
Created attachment 183000 [details]
Output from the crashing rekonq

QtWebKit browsers (tested with rekonq and arora) crash with qtwebkit 2.3git20130115 package for arch linux.

The package consists of the latest tarball of the qtwebkit-2.3 branch from gitorious with a single patch that enables settings->acceleratedCompositingEnabled(), taken from the bug https://bugs.webkit.org/show_bug.cgi?id=106892.

In attachment I provided backtraces from rekonq (2.0) and arora (0.11.0). They seem to crash because of some fastMalloc call, so this is probably a NULL pointer issue or something in that vicinity.

Reverting qtwebkit to qtwebkit 2.2.2 fixes the problem.

I am using up-to-date Arch Linux with the following versions of relevant packages:

extra/arora 0.11.0-3
community/rekonq 2.0-2
extra/qtwebkit 2.3git20130115-1
extra/qt 4.8.4-1
Comment 1 Filip Brcic 2013-01-16 10:03:11 PST
Created attachment 183001 [details]
Output from the crashing arora
Comment 2 Benjamin Poulain 2013-01-17 14:34:23 PST
The crashlog are useless because they are not symbolicated.

Can you please attach:
-Disassembly at the position of the crash.
-Symbolicated crash logs.
Comment 3 Allan Sandfeld Jensen 2013-01-19 13:16:49 PST
The backtraces are not very helpfull, but this bug could be the same as https://bugs.webkit.org/show_bug.cgi?id=104525, in which case it should be solved in the latest version of qtwebkit-2.3
Comment 4 Andrea Scarpino 2013-01-26 07:14:11 PST
On Arch Linux the user who reported this bug solved building qtwebkit with --no-sse2
Comment 5 Allan Sandfeld Jensen 2013-02-05 06:00:54 PST
Thank. I will close the bug assuming it was a problem with wrong instruction set then.