Bug 106599 - XSLT should traverse into template content when sourcing a document, and document.evaluate (XPath) should not
Summary: XSLT should traverse into template content when sourcing a document, and docu...
Status: RESOLVED DUPLICATE of bug 106491
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Rafael Weinstein
URL:
Keywords:
Depends on:
Blocks: 103547
  Show dependency treegraph
 
Reported: 2013-01-10 13:57 PST by Rafael Weinstein
Modified: 2013-01-11 12:16 PST (History)
4 users (show)

See Also:


Attachments
Patch (6.44 KB, patch)
2013-01-10 14:03 PST, Rafael Weinstein
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Weinstein 2013-01-10 13:57:58 PST
See https://www.w3.org/Bugs/Public/show_bug.cgi?id=20483
Comment 1 Rafael Weinstein 2013-01-10 14:03:59 PST
Created attachment 182205 [details]
Patch
Comment 2 Rafael Weinstein 2013-01-10 14:04:52 PST
Note that these tests will work without further code changes once https://bugs.webkit.org/show_bug.cgi?id=106491 lands.
Comment 3 Rafael Weinstein 2013-01-11 12:16:14 PST
Merging this with 106491, since fixing XHTML parsing fixes this (and allows these tests to pass).

*** This bug has been marked as a duplicate of bug 106491 ***