Bug 104431 - [EFL] Change the minimum required EFL version to 1.6
Summary: [EFL] Change the minimum required EFL version to 1.6
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-07 21:25 PST by Laszlo Gombos
Modified: 2012-12-10 13:54 PST (History)
5 users (show)

See Also:


Attachments
proposed patch (3.69 KB, patch)
2012-12-07 21:31 PST, Laszlo Gombos
no flags Details | Formatted Diff | Diff
update the patch with the justification (3.69 KB, patch)
2012-12-10 09:06 PST, Laszlo Gombos
no flags Details | Formatted Diff | Diff
right patch this time (4.21 KB, patch)
2012-12-10 09:52 PST, Laszlo Gombos
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Laszlo Gombos 2012-12-07 21:25:22 PST
Revision http://trac.webkit.org/changeset/130887 changed the minimum required EFL version to 1.7. I have found that EFL port of WebKit builds on public releases of EFL labeled as 1.6+ and found no evidence that 1.7 is indeed required.

Note that the "reference" EFL version that is used by most developers and in the buildbot as it is specified in the jhbuild configuration (http://trac.webkit.org/browser/trunk/Tools/efl/jhbuild.modules) does not need to be downgraded and should continue to advance inversion as it was rightly pointed out by Raphael as well in another bug (https://bugs.webkit.org/show_bug.cgi?id=97523#c4).
Comment 1 Laszlo Gombos 2012-12-07 21:31:19 PST
Created attachment 178333 [details]
proposed patch

This is technically a build fix for my environment.
Comment 2 Kenneth Rohde Christiansen 2012-12-08 03:58:22 PST
Comment on attachment 178333 [details]
proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=178333&action=review

> ChangeLog:11
> +
> +        Change the minimum required EFL version to 1.6 from 1.7.
> +        The elementary EFL package is only required to build MiniBrowser,
> +        so I moved the required only to the Minibrowser CMake file.
> +

I don't see the point in this. Why promote older versions for no reason? The packages might not be required, but they might contain bugfixes and other api that we might want to use without having to bump version back
Comment 3 Kenneth Rohde Christiansen 2012-12-08 03:58:47 PST
I rather want us to push the most recent version tested to work
Comment 4 Laszlo Gombos 2012-12-10 09:06:23 PST
Created attachment 178568 [details]
update the patch with the justification

> Why promote older versions for no reason?

The reason is to support building for Tizen (trunk).

> I rather want us to push the most recent version tested to work.

I agree with the desire to update Tizen to use EFL v1.7+, but until the update is not in place I think it is a good compromise to enable (not necessary promote) building using EFL v1.6+.

I updated the patch to include the reasoning and a warning message if EFL v1.6 is used.
Comment 5 Kenneth Rohde Christiansen 2012-12-10 09:39:09 PST
Comment on attachment 178568 [details]
update the patch with the justification

View in context: https://bugs.webkit.org/attachment.cgi?id=178568&action=review

> ChangeLog:10
> +
> +        Change the minimum required EFL version to 1.6 from 1.7.
> +        The elementary EFL package is only required to build MiniBrowser,
> +        so I moved the required only to the Minibrowser CMake file.

Where is this justification?
Comment 6 Laszlo Gombos 2012-12-10 09:52:21 PST
Created attachment 178575 [details]
right patch this time
Comment 7 WebKit Review Bot 2012-12-10 13:54:55 PST
Comment on attachment 178575 [details]
right patch this time

Clearing flags on attachment: 178575

Committed r137203: <http://trac.webkit.org/changeset/137203>
Comment 8 WebKit Review Bot 2012-12-10 13:54:59 PST
All reviewed patches have been landed.  Closing bug.