Bug 103033 - INPUT_MULTIPLE_FIELDS_UI: Refactoring: Do not call updateInnerTextValue if only read-only sub-fields have values
Summary: INPUT_MULTIPLE_FIELDS_UI: Refactoring: Do not call updateInnerTextValue if on...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kent Tamura
URL:
Keywords:
Depends on: 102645
Blocks: 102861
  Show dependency treegraph
 
Reported: 2012-11-22 00:40 PST by Kent Tamura
Modified: 2012-11-22 05:46 PST (History)
5 users (show)

See Also:


Attachments
Patch (8.15 KB, patch)
2012-11-22 00:57 PST, Kent Tamura
no flags Details | Formatted Diff | Diff
Patch for landing (8.16 KB, patch)
2012-11-22 01:08 PST, Kent Tamura
no flags Details | Formatted Diff | Diff
Patch for landing (8.15 KB, patch)
2012-11-22 01:11 PST, Kent Tamura
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Tamura 2012-11-22 00:40:03 PST
INPUT_MULTIPLE_FIELDS_UI: Refactoring: Do not call updateInnerTextValue if only read-only sub-fields have values
Comment 1 Kent Tamura 2012-11-22 00:57:44 PST
Created attachment 175615 [details]
Patch
Comment 2 Kentaro Hara 2012-11-22 01:03:25 PST
Comment on attachment 175615 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=175615&action=review

> LayoutTests/fast/forms/time-multiple-fields/time-multiple-fields-value-set-empty.html:23
> +shouldNotBe('eventSender.keyDown("upArrow"); getUserAgentShadowTextContent(input)', 'initialText');

Instead of shouldNotBe(), how about dumping the value of getUserAgentShadowTextContent(input) ? Given that you're dumping initialText, the test result is already platform-dependent.
Comment 3 Kent Tamura 2012-11-22 01:08:27 PST
Created attachment 175616 [details]
Patch for landing
Comment 4 Kent Tamura 2012-11-22 01:10:31 PST
Comment on attachment 175615 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=175615&action=review

>> LayoutTests/fast/forms/time-multiple-fields/time-multiple-fields-value-set-empty.html:23
>> +shouldNotBe('eventSender.keyDown("upArrow"); getUserAgentShadowTextContent(input)', 'initialText');
> 
> Instead of shouldNotBe(), how about dumping the value of getUserAgentShadowTextContent(input) ? Given that you're dumping initialText, the test result is already platform-dependent.

Yeah, it's better for test result readability.
The time formats in en-US locale on ICU/Windows/Mac are identical. We don't need to worry about platform dependency here.
Comment 5 Kent Tamura 2012-11-22 01:11:30 PST
Created attachment 175618 [details]
Patch for landing
Comment 6 WebKit Review Bot 2012-11-22 05:46:41 PST
Comment on attachment 175618 [details]
Patch for landing

Clearing flags on attachment: 175618

Committed r135510: <http://trac.webkit.org/changeset/135510>
Comment 7 WebKit Review Bot 2012-11-22 05:46:45 PST
All reviewed patches have been landed.  Closing bug.