Bug 102271 - [CF]: XMLHttpRequest "timeout" events firing as "error" events
Summary: [CF]: XMLHttpRequest "timeout" events firing as "error" events
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 100349 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-14 12:37 PST by Joseph Pecoraro
Modified: 2012-11-14 19:49 PST (History)
7 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (1.99 KB, patch)
2012-11-14 12:41 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2012-11-14 12:37:09 PST
When USE(CFNETWORK) timeout ResourceErrors are not being marked timeouts.
Init the timeout flag in the USE(CFNETWORK) side of ResourceError just like:
<http://webkit.org/b/99478> Init timeout flag in ResourceErrorMac

Patch to follow.
Comment 1 Joseph Pecoraro 2012-11-14 12:37:51 PST
<rdar://problem/12693157>
Comment 2 Joseph Pecoraro 2012-11-14 12:41:43 PST
Created attachment 174229 [details]
[PATCH] Proposed Fix

Do the same as the r131499: <http://trac.webkit.org/changeset/131499> but
for the USE(CFNETWORK) ResourceError constructors.
Comment 3 Alexey Proskuryakov 2012-11-14 13:41:24 PST
Isn't this a duplicate of bug 100349?
Comment 4 Alexey Proskuryakov 2012-11-14 13:42:55 PST
The patch looks good to me, but the same change has been found to not work in practice in bug 100349.
Comment 5 Joseph Pecoraro 2012-11-14 16:52:45 PST
Hmm, this does look identical. I can't explain why it doesn't fix the Windows bots. It fixed
these tests on the iOS port.
Comment 6 David Kilzer (:ddkilzer) 2012-11-14 17:05:05 PST
(In reply to comment #4)
> The patch looks good to me, but the same change has been found to not work in practice in bug 100349.

Has anyone run the test on Windows to find out what error code it is returning in this case?  If it works on iOS, then perhaps there is a bug in the Windows port of CFNetwork.
Comment 7 David Kilzer (:ddkilzer) 2012-11-14 17:07:57 PST
Comment on attachment 174229 [details]
[PATCH] Proposed Fix

r=me
Comment 8 WebKit Review Bot 2012-11-14 17:31:04 PST
Comment on attachment 174229 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 174229

Committed r134702: <http://trac.webkit.org/changeset/134702>
Comment 9 WebKit Review Bot 2012-11-14 17:31:08 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Alexey Proskuryakov 2012-11-14 19:49:44 PST
*** Bug 100349 has been marked as a duplicate of this bug. ***