Bug 102270 - IndexedDB: Replace int64 with int64_t
Summary: IndexedDB: Replace int64 with int64_t
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 45110
  Show dependency treegraph
 
Reported: 2012-11-14 12:33 PST by Michael Pruett
Modified: 2012-11-14 14:42 PST (History)
4 users (show)

See Also:


Attachments
Replace int64 with int64_t (3.02 KB, patch)
2012-11-14 12:38 PST, Michael Pruett
tony: review+
Details | Formatted Diff | Diff
Replace int64 with int64_t (3.09 KB, patch)
2012-11-14 13:33 PST, Michael Pruett
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Pruett 2012-11-14 12:33:58 PST
There are currently two uses of the non-standard type int64 in IndexedDB which should be changed to the C99/C++11 int64_t type.

The int64 type is defined in Chromium's basictypes.h but is not defined for other platforms.
Comment 1 Michael Pruett 2012-11-14 12:38:39 PST
Created attachment 174228 [details]
Replace int64 with int64_t
Comment 2 Tony Chang 2012-11-14 13:23:14 PST
Comment on attachment 174228 [details]
Replace int64 with int64_t

View in context: https://bugs.webkit.org/attachment.cgi?id=174228&action=review

> Source/WebCore/ChangeLog:8
> +
> +        Tests: storage/indexeddb/*

Please put the reason for the change here. For example, "This is needed for JSC because ...".
Comment 3 Joshua Bell 2012-11-14 13:24:37 PST
> Please put the reason for the change here. For example, "This is needed for JSC because ...".

And "Cleaning up coding inconsistencies, no behavior change" is acceptable as a reason.
Comment 4 Michael Pruett 2012-11-14 13:33:57 PST
Created attachment 174242 [details]
Replace int64 with int64_t
Comment 5 WebKit Review Bot 2012-11-14 14:12:53 PST
Comment on attachment 174242 [details]
Replace int64 with int64_t

Rejecting attachment 174242 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
: Merge conflict in Source/WebCore/ChangeLog
Failed to merge in the changes.
Patch failed at 0001 Coordinated Graphics: Rename m_CoordinatedGraphicsLayerClient to m_coordinator

When you have resolved this problem run "git rebase --continue".
If you would prefer to skip this patch, instead run "git rebase --skip".
To restore the original branch and stop rebasing run "git rebase --abort".

rebase refs/remotes/origin/master: command returned error: 1

Died at Tools/Scripts/update-webkit line 154.

Full output: http://queues.webkit.org/results/14832512
Comment 6 WebKit Review Bot 2012-11-14 14:42:48 PST
Comment on attachment 174242 [details]
Replace int64 with int64_t

Clearing flags on attachment: 174242

Committed r134673: <http://trac.webkit.org/changeset/134673>
Comment 7 WebKit Review Bot 2012-11-14 14:42:52 PST
All reviewed patches have been landed.  Closing bug.