Bug 101594 - Make libsecret-1-dev an optional dependency for building gtk
Summary: Make libsecret-1-dev an optional dependency for building gtk
Status: RESOLVED DUPLICATE of bug 109195
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-08 05:56 PST by Vivek Galatage
Modified: 2013-02-12 09:44 PST (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vivek Galatage 2012-11-08 05:56:20 PST
I am trying to build webkit on ubuntu 12.04 64-bit and getting the configure error for the package libsecret-1-dev.

I had to take the sources from http://git.gnome.org/browse/libsecret/ and manually build it for this distro to get the build working.

Would it be possible to make this library dependency optional?

The link http://packages.ubuntu.com/search?keywords=libsecret-1-dev says this is available 12.10 onwards.
Comment 1 Dominik Röttsches (drott) 2012-11-08 06:13:47 PST
Alternatively, you can download and install the following packages manually from the ubuntu repos:
gir1.2-secret-1_0.10-0ubuntu1_amd64.deb
libsecret-1-0_0.10-0ubuntu1_amd64.deb
libsecret-1-dev_0.10-0ubuntu1_amd64.deb
libsecret-common_0.10-0ubuntu1_all.deb
Comment 2 Martin Robinson 2013-02-12 09:43:50 PST

*** This bug has been marked as a duplicate of bug 109195 ***
Comment 3 Martin Robinson 2013-02-12 09:44:38 PST
You can now run ./Tools/jhbuild/jhbuild-wrapper --gtk buildone libsecret.