Bug 101478 - Copy of CSS transformed text with text-transform contains CSS transformations
Summary: Copy of CSS transformed text with text-transform contains CSS transformations
Status: RESOLVED DUPLICATE of bug 43202
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-07 08:13 PST by Mehdi Kabab
Modified: 2012-11-07 16:11 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mehdi Kabab 2012-11-07 08:13:34 PST
When I copy some text that has been transformed with some text-transform CSS property, the copied text does contain the style transformations.

But when I copy some text, I only want to copy its content, and not its CSS styles.

For example, if the title of an article is turned into uppercase with CSS, I don't want to copy/paste uppercase text, but only its source.

I can read in the bug 3429 that the current behaviour is made on purpose: however it turns out to be quite annoying on a daily basis.
Comment 1 Alexey Proskuryakov 2012-11-07 16:11:53 PST

*** This bug has been marked as a duplicate of bug 43202 ***