Bug 96445

Summary: Introduce SelectorCheckingEffects.
Product: WebKit Reporter: Dimitri Glazkov (Google) <dglazkov>
Component: New BugsAssignee: Dimitri Glazkov (Google) <dglazkov>
Status: NEW ---    
Severity: Normal CC: eric, kling, koivisto
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 96425    
Attachments:
Description Flags
Patch koivisto: review-

Description Dimitri Glazkov (Google) 2012-09-11 16:08:21 PDT
Introduce StyleCheckingEffects.
Comment 1 Dimitri Glazkov (Google) 2012-09-11 16:11:26 PDT
Created attachment 163472 [details]
Patch
Comment 2 Dimitri Glazkov (Google) 2012-09-11 16:11:52 PDT
This
Comment 3 Dimitri Glazkov (Google) 2012-09-11 16:12:26 PDT
This is based off the patch on bug 96425. Expect purple until it lands.
Comment 4 Eric Seidel (no email) 2012-09-11 16:22:13 PDT
Comment on attachment 163472 [details]
Patch

Effects is kinda an odd name, but this looks fine.  I don't have any better suggestions. :)
Comment 5 Antti Koivisto 2012-09-12 06:03:50 PDT
Comment on attachment 163472 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=163472&action=review

> Source/WebCore/css/SelectorChecker.h:80
> +    // Some information can't be determined until the selector checking runs.
> +    // This struct captures that information.
> +    struct SelectorCheckingEffects {

Name "Effects" doesn't make sense to me here. Wouldn't it be better to capture all return values (including SelectorMatch) to something like SelectorCheckResult?

r- for now.
Comment 6 Dimitri Glazkov (Google) 2012-09-12 09:12:16 PDT
(In reply to comment #5)
> (From update of attachment 163472 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=163472&action=review
> 
> > Source/WebCore/css/SelectorChecker.h:80
> > +    // Some information can't be determined until the selector checking runs.
> > +    // This struct captures that information.
> > +    struct SelectorCheckingEffects {
> 
> Name "Effects" doesn't make sense to me here. Wouldn't it be better to capture all return values (including SelectorMatch) to something like SelectorCheckResult?

Yup. Sounds good.

> 
> r- for now.