Bug 93334

Summary: [V8] Move setIsolatedWorldSecurityOrigin() from V8Proxy to ScriptController
Product: WebKit Reporter: Kentaro Hara <haraken>
Component: WebCore JavaScriptAssignee: Kentaro Hara <haraken>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, japhet, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 93095    
Attachments:
Description Flags
Patch none

Description Kentaro Hara 2012-08-06 21:54:19 PDT
The goal is to move m_isolatedWorlds, m_isolatedWorldSecurityOrigins and related methods from V8Proxy to ScriptController. As a starting point, in this bug we move setIsolatedWorldSecurityOrigin().
Comment 1 Kentaro Hara 2012-08-06 22:09:45 PDT
Created attachment 156861 [details]
Patch
Comment 2 Adam Barth 2012-08-07 15:00:11 PDT
Comment on attachment 156861 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=156861&action=review

> Source/WebCore/bindings/v8/ScriptController.cpp:183
>  void ScriptController::setIsolatedWorldSecurityOrigin(int worldID, PassRefPtr<SecurityOrigin> securityOrigin)

A better name for this function is something like setSecurityOriginForIsolatedWorld, but don't feel like you need to go renaming crazy in this patch.
Comment 3 Kentaro Hara 2012-08-07 17:04:33 PDT
(In reply to comment #2)
> A better name for this function is something like setSecurityOriginForIsolatedWorld, but don't feel like you need to go renaming crazy in this patch.

This method is exposed to the Chromium WebKit API. If we want to rename it, we should rename the API name too. If you want, I'll do it. WDYT?

http://code.google.com/codesearch#OAMlx_jo-ck/src/third_party/WebKit/Source/WebKit/chromium/public/WebFrame.h&exact_package=chromium&q=setIsolatedWorldSecurityOrigin&type=cs&l=258

Either way let me land this patch first.
Comment 4 WebKit Review Bot 2012-08-07 18:18:20 PDT
Comment on attachment 156861 [details]
Patch

Clearing flags on attachment: 156861

Committed r124962: <http://trac.webkit.org/changeset/124962>
Comment 5 WebKit Review Bot 2012-08-07 18:18:23 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Adam Barth 2012-08-07 22:28:27 PDT
It's probably too much work to rename the API.
Comment 7 Kentaro Hara 2012-08-07 22:30:24 PDT
OK, then let's keep it as is.