Bug 90169

Summary: Effective Image size deviates from width and height attributes with sub-pixel layout
Product: WebKit Reporter: Dominik Röttsches (drott) <d-r>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: eae, leviw, tmpsantos
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 60318, 89458    
Attachments:
Description Flags
014-wdiff.html failure
none
Simplified test case none

Description Dominik Röttsches (drott) 2012-06-28 06:28:49 PDT
Created attachment 149937 [details]
014-wdiff.html failure

When enabling sub-pixel layout, the DRT values for RenderImages are deviating from the specified width and height.
This shows for example in fast/block/basic/014-wdiff.html (diff attached).

I don't see a reason why the image size should be changed from what's specified as height (21) to 22 pixels height and then moved one pixel up (-1).

I'm investigating, but if this is a known issue, Levi & Emil - please let me know.
Comment 1 Dominik Röttsches (drott) 2012-07-03 06:34:59 PDT
Created attachment 150597 [details]
Simplified test case

This test case still results in

layer at (0,0) size 800x600
  RenderView at (0,0) size 800x600
layer at (0,0) size 800x600
  RenderBlock {HTML} at (0,0) size 800x600
    RenderBody {BODY} at (8,8) size 784x584
      RenderImage {IMG} at (0,-1) size 21x22 [bgcolor=#008000]
      RenderText {#text} at (0,0) size 0x0

The image being vertically moved up, and sized larger than specified. This seems wrong to me. It's likely casued by the vertical-align: middle declaration, resulting in a shifted positioning.
Comment 2 Emil A Eklund 2012-07-03 09:56:46 PDT
I believe the fix for 90354 addressed this.
Comment 3 Dominik Röttsches (drott) 2012-07-04 04:18:39 PDT
Unfortunately, bug 90354 doesn't solve this.
Comment 4 Dominik Röttsches (drott) 2012-07-19 02:11:47 PDT
Argh... I was soo close to finding the reason :-) - Good to see it's fixed.

*** This bug has been marked as a duplicate of bug 91464 ***