Bug 78341

Summary: [WIN] Add abstraction for HWND_MESSAGE
Product: WebKit Reporter: Patrick R. Gansterer <paroga>
Component: PlatformAssignee: Patrick R. Gansterer <paroga>
Status: RESOLVED FIXED    
Severity: Normal CC: aroben, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Windows 7   
Bug Depends on: 78340    
Bug Blocks: 76781    
Attachments:
Description Flags
Patch
none
Patch none

Description Patrick R. Gansterer 2012-02-10 02:40:16 PST
[WIN] Add abstraction for HWND_MESSAGE
Comment 1 Patrick R. Gansterer 2012-02-10 02:44:44 PST
Created attachment 126483 [details]
Patch
Comment 2 Adam Roben (:aroben) 2012-02-13 07:48:46 PST
Comment on attachment 126483 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=126483&action=review

> Source/WebCore/platform/win/WindowsExtras.h:36
> +#ifdef HWND_MESSAGE
> +const HWND kHwndMessage = HWND_MESSAGE;
> +#else
> +const HWND kHwndMessage = 0;
> +#endif

Why not just do this?

#ifndef HWND_MESSAGE
const HWND HWND_MESSAGE = 0;
#endif

Then we could use HWND_MESSAGE everywhere.
Comment 3 Patrick R. Gansterer 2012-02-13 08:38:53 PST
Created attachment 126777 [details]
Patch
Comment 4 WebKit Review Bot 2012-02-13 08:45:09 PST
Attachment 126777 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCor..." exit_code: 1

Source/WebCore/platform/win/WindowsExtras.h:33:  HWND_MESSAGE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 1 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 WebKit Review Bot 2012-02-13 11:54:51 PST
Comment on attachment 126777 [details]
Patch

Clearing flags on attachment: 126777

Committed r107592: <http://trac.webkit.org/changeset/107592>
Comment 6 WebKit Review Bot 2012-02-13 11:54:56 PST
All reviewed patches have been landed.  Closing bug.