Bug 76007

Summary: Audio with HTML5 do not work with latest webkit on N9 Qt HTML application
Product: WebKit Reporter: Rahul <rahul.nimbalkar>
Component: WebKit QtAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: bruno.abinader, rahul.nimbalkar, stephan.binner
Priority: P2 Keywords: HTML5, Qt
Version: 528+ (Nightly build)   
Hardware: Other   
OS: Other   

Description Rahul 2012-01-10 16:24:54 PST
Latest version of libqt4webkit fails to play audio. I concluded this as the same Qt/Html5 application works fine with older images (wk 40 or wk 41).

Week 41 or earlier have libqt4webkit~2.1.x and latest images have libqt4webkit~2.2.x. I am not sure about actual reason but when I downgraded webkit on N9 with latest images, my application worked fine. So I believe its fair enough to blame latest version of Webkit for audio failure with HTML5 Qt application
Comment 1 Bruno Abinader (history only) 2012-01-20 07:52:58 PST
Hi Rahul, thank you for the feedback. I've found out that a specific commit 429bbaa92d60a22a2264e0a1d909dd3f070249a7 from 2.1 branch is not merged into 2.2, which is a workaround for QtMultimedia bug (QTMOBILITY-1090). As the commit log says, a previous WebKit bug 53682 has been created for this. We're going to handle this internally.

*** This bug has been marked as a duplicate of bug 53682 ***