Bug 72803
Summary: | Web Inspector: remove addStyleClass, removeStyleClass and hasStyleClass | ||
---|---|---|---|
Product: | WebKit | Reporter: | Timothy Hatcher <timothy> |
Component: | Web Inspector (Deprecated) | Assignee: | Nobody <webkit-unassigned> |
Status: | RESOLVED FIXED | ||
Severity: | Normal | CC: | apavlov, burg, bweinstein, joepeck, keishi, loislo, pfeldman, pmuellr, rik, yurys |
Priority: | P2 | ||
Version: | 528+ (Nightly build) | ||
Hardware: | All | ||
OS: | All |
Timothy Hatcher
These functions are just thin wrappers around classList now. We should use classList cirectly instead of these functions.
Attachments | ||
---|---|---|
Add attachment proposed patch, testcase, etc. |
Timothy Hatcher
I did TreeOutline in r101313 because I had done it internally on a copy we use in Safari and I upstreamed our changes.
We should do the rest of the Inspector next!
Joseph Pecoraro
There was a comment in:
<http://webkit.org/b/55758> Web Inspector: Make use of element.classList in utilities.js
> Bug 56096 fixes the first item, and we have agreed with pfeldman that the
> add/remove/hasStyleClass improve readability, so the classList methods will
> not be inlined. We have reached our primary goal of getting rid of regex-based
> operations and the className property modification (which is slow).
Timothy Hatcher
I think reducing out own wrappers is a good idea, especially if they are so thin as these are.
We should also remove Function.prototype.bind, which is native in JSC at least not sure about V8.
Timothy Hatcher
reducing our own*