Bug 70794

Summary: Need to implement flex-line-pack
Product: WebKit Reporter: Ojan Vafai <ojan>
Component: Layout and RenderingAssignee: Tony Chang <tony>
Status: RESOLVED FIXED    
Severity: Normal CC: tony
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 81427    
Bug Blocks: 62048    
Attachments:
Description Flags
Patch ojan: review+

Comment 1 Tony Chang 2012-03-16 10:40:38 PDT
*** Bug 80328 has been marked as a duplicate of this bug. ***
Comment 2 Tony Chang 2012-03-28 17:17:14 PDT
Created attachment 134454 [details]
Patch
Comment 3 Ojan Vafai 2012-03-28 19:35:24 PDT
Comment on attachment 134454 [details]
Patch

I'm amazed how simple this patch is after all your refactors. It took me a couple reads to understand how setting crossAxisExtent/crossAxisOffset just makes everything magically work. I'm not sure how to make it any more clear though.
Comment 4 Tony Chang 2012-03-29 10:16:55 PDT
Committed r112544: <http://trac.webkit.org/changeset/112544>