Bug 63397

Summary: SVGAnimatedType should support SVGNumberOptionalNumber animation
Product: WebKit Reporter: Dirk Schulze <krit>
Component: SVGAssignee: Dirk Schulze <krit>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, webkit.review.bot, zimmermann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 41761    
Attachments:
Description Flags
Patch zimmermann: review+

Description Dirk Schulze 2011-06-26 02:46:49 PDT
SVGAnimatedType should support SVGNumberOptionalNumber animation.
Comment 1 Dirk Schulze 2011-06-26 03:04:07 PDT
Created attachment 98620 [details]
Patch
Comment 2 WebKit Review Bot 2011-06-26 03:06:24 PDT
Attachment 98620 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/svg/..." exit_code: 1

Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:40:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:40:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:41:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:41:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:43:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:43:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.h:43:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:49:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:49:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:60:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:60:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:78:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:78:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Source/WebCore/svg/SVGAnimatedNumberOptionalNumber.cpp:78:  The parameter type should use PassOwnPtr instead of OwnPtr.  [readability/pass_ptr] [5]
Total errors found: 14 in 27 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Nikolas Zimmermann 2011-06-26 03:44:08 PDT
Comment on attachment 98620 [details]
Patch

r=me!
Comment 4 Dirk Schulze 2011-06-26 04:25:04 PDT
Committed r89766: <http://trac.webkit.org/changeset/89766>
Comment 5 Adam Barth 2011-06-26 23:15:56 PDT
This patch added

using namespace std;

to a header file.  That seems pretty uncool.  /me will fixenate.
Comment 6 Adam Barth 2011-06-26 23:39:14 PDT
Fixenated in http://trac.webkit.org/changeset/89786
Comment 7 Dirk Schulze 2011-06-26 23:42:11 PDT
(In reply to comment #6)
> Fixenated in http://trac.webkit.org/changeset/89786

Oh, sorry. Thanks for fixing.
Comment 8 Adam Barth 2011-06-26 23:46:10 PDT
For the record, this caused broke the clang build.  We don't have much clang coverage on webkit.org, so it's easy to break that build.  Adding more coverage is on my list of things I'd like to do, but it's not at the top yet.