|Summary:||[meta] Replace uses of tx/ty with IntSize|
|Product:||WebKit||Reporter:||Levi Weintraub <leviw>|
|Component:||Layout and Rendering||Assignee:||Nobody <webkit-unassigned>|
|Severity:||Normal||CC:||eae, eric, hyatt, jamesr, leviw, mjs|
|Version:||528+ (Nightly build)|
|Bug Depends on:||60490, 60578, 60679|
Description Levi Weintraub 2011-05-06 15:02:43 PDT
tx/ty offsets used in painting are confusing and should be combined into either an IntSize or IntPoint -- likely IntSize. See the URL for a related discussion from WebKit-Dev.
Comment 1 Levi Weintraub 2011-05-09 11:43:35 PDT
Considering how frequently tx/ty are used to construct points AND sizes, I now feel like this could warrant a new type to avoid the mess of calling this an point or size then repeatedly using it another way. Perhaps PaintOffset/IntOffset, which would allow easy conversion to points and sizes.
Comment 2 Levi Weintraub 2011-05-10 13:59:12 PDT
Updating with the name and making this a meta bug to track all the changes that'll help us make this switch.
Comment 3 Levi Weintraub 2011-06-06 19:17:02 PDT
We already have a metabug tracking this work, and we ended up using IntPoint instead of IntSize.