Bug 59281

Summary: REGRESSION: (non-Mac) <meter>'s bar part isn't rendered for with -webkit-writing-mode: vertical-lr from r82899
Product: WebKit Reporter: Hajime Morrita <morrita>
Component: DOMAssignee: Hajime Morrita <morrita>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, dglazkov, tkent
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 50661    
Attachments:
Description Flags
Patch tkent: review+

Description Hajime Morrita 2011-04-23 13:09:34 PDT
From Bug 58149.
Comment 1 Hajime Morrita 2011-04-23 15:07:44 PDT
Created attachment 90860 [details]
Patch
Comment 2 Adam Barth 2011-04-23 15:40:07 PDT
Looks like this patch causes fast/dom/HTMLMeterElement/meter-element.html to fail.
Comment 3 Hajime Morrita 2011-04-23 15:51:01 PDT
(In reply to comment #2)
> Looks like this patch causes fast/dom/HTMLMeterElement/meter-element.html to fail.
Sounds false positive. That test is which exactly this change is trying to fix....
Comment 4 Kent Tamura 2011-04-23 15:54:09 PDT
Comment on attachment 90860 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=90860&action=review

> Source/WebCore/ChangeLog:8
> +        style for -webkit-meter-bar and -webkit-progress-bar missed width property, which caused unexpected layout result

style -> Style
Comment 5 Adam Barth 2011-04-23 15:55:31 PDT
> Sounds false positive. That test is which exactly this change is trying to fix....

Interesting.  Running the tests on the cr-linux-ews is very new.  It's entirely possible that this is a false positive.
Comment 6 Hajime Morrita 2011-04-23 16:11:21 PDT
Kent-san, thank you for reviewing at the weekend :D
I'll fix it before landing.

Adam,
> > Sounds false positive. That test is which exactly this change is trying to fix....
> 
> Interesting.  Running the tests on the cr-linux-ews is very new.  It's entirely possible that this is a false positive.
This patch removes a line from test_expectation because it will be fixed by this patch.
I wonder if that case is considered.
I'll land this and see what happens.
Comment 7 Hajime Morrita 2011-04-23 16:16:33 PDT
Committed r84745: <http://trac.webkit.org/changeset/84745>
Comment 8 Adam Barth 2011-04-23 17:05:06 PDT
As predicted, the test is now failing on the bots:

http://build.chromium.org/p/chromium.webkit/waterfall?builder=Webkit%20Linux
Comment 9 Hajime Morrita 2011-04-23 17:08:30 PDT
> http://build.chromium.org/p/chromium.webkit/waterfall?builder=Webkit%20Linux
You are right. I'll skip it again...
Comment 10 Hajime Morrita 2011-04-23 17:08:48 PDT
> You are right. I'll skip it again...
Not skip, just mark as fail.