Bug 57716

Summary: REGRESSION: Fullscreen HTML5 Video fails to resize on YouTube when using ClickToFlash
Product: WebKit Reporter: sharikov.suba
Component: MediaAssignee: Jer Noble <jer.noble>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: ap, edwardjsabol, eric.carlson, hello, jer.noble, marc.hoyois, rick.baumhauer
Priority: P1 Keywords: Regression
Version: 528+ (Nightly build)   
Hardware: Macintosh Intel   
OS: OS X 10.6   
Attachments:
Description Flags
screenshot of bug
none
Video clip of behavior
none
Screenshot of Vimeo fullscreen behavior
none
Screenshot of improper fullscreen video rendering on apple.com
none
Screenshot of improper fullscreen video rendering on apple.com
none
ClicktoFlash fullscreen issue not resolved on r83831 none

Description sharikov.suba 2011-04-02 18:22:42 PDT
When clicking on fullscreen for html5 videos, the video fails to resize.   

*Tested with latest safari, which does not mimic this behavior.
Comment 1 sharikov.suba 2011-04-02 18:24:17 PDT
Created attachment 87992 [details]
screenshot of bug
Comment 2 Alexey Proskuryakov 2011-04-03 21:48:27 PDT
Could you please confirm that you are seeing this problem with nightly builds from <http://nightly.webkit.org>, but not with Safari 5.0.4?
Comment 3 sharikov.suba 2011-04-04 02:21:03 PDT
Yes, this happens only with the webkit nightly build.  I've isolated this behavior to the the clicktoflash 2.14 extension ( http://hoyois.github.com/safariextensions/clicktoflash/ ).
Comment 4 Alexey Proskuryakov 2011-04-04 09:05:32 PDT
ClickToFlash shouldn't be affecting HTML5 video.

Could you please provide more detailed steps to reproduce, so that we could determine what is happening on the page you're seeing this on?
Comment 5 sharikov.suba 2011-04-04 15:44:55 PDT
Created attachment 88144 [details]
Video clip of behavior
Comment 6 sharikov.suba 2011-04-04 15:53:07 PDT
Attached is the video of the behavior.  

Website:  youtube.com
HTML5 Video Extension: clicktoflash 2.14

Related Bug?:   https://bugs.webkit.org/show_bug.cgi?id=57795
Comment 7 Alexey Proskuryakov 2011-04-04 16:41:25 PDT
Thanks!

Is it correct that you don't have HTML5 video enabled via <http://www.youtube.com/html5>? Can you see the same problem if you enable it?
Comment 8 sharikov.suba 2011-04-04 17:35:31 PDT
I've tried with youtube HTML5 video enabled and disabled, but enabling never works as it always reverts to flash.  Clicktoflash intervenes and forces it to use html5.

One thing to note is that if I go to a site that natively plays html5 video ( apple.com, vimeo ), fullscreen works properly with their own designated html5 video players.  I've also installed and tested youtube5 extension ( http://www.verticalforest.com/youtube5-extension/ ) and the fullscreen works properly.
Comment 9 Edward Sabol 2011-04-11 10:10:03 PDT
I have this problem as well. It started with a recent WebKit Nightly.
Comment 10 Edward Sabol 2011-04-11 10:38:57 PDT
Created attachment 89026 [details]
Screenshot of Vimeo fullscreen behavior

I just wanted to add that the problem occurs with Vimeo videos as well. Clicking the button to go fullscreen turns the background of the web site black, but any graphics on the web page are still visible. The video is centered, but it doesn't enlarge to take up the entire screen. I'm uploading a screenshot of a "fullscreen" Vimeo video being played.

This is with the latest Webkit Nightly (r83424).
Comment 11 Graham Ballantyne 2011-04-13 22:24:29 PDT
Full screen video via the Youtube5 extension stopped working for me in the last few Webkit nightlies (verified on r83750). I'm also seeing the Vimeo problem mentioned by Edward, as well as issues with fullscreen on apple.com (see attachment).
Comment 12 Graham Ballantyne 2011-04-13 22:25:16 PDT
Created attachment 89533 [details]
Screenshot of improper fullscreen video rendering on apple.com
Comment 13 Graham Ballantyne 2011-04-13 22:26:11 PDT
Created attachment 89534 [details]
Screenshot of improper fullscreen video rendering on apple.com
Comment 14 Jer Noble 2011-04-14 11:03:23 PDT
This is probably a duplicate of bug #58291.  Can you verify that it still occurs with a nightly build > r83654?
Comment 15 Graham Ballantyne 2011-04-14 11:59:29 PDT
Vimeo is working on r83831; YouTube via YouTube5 and full-screen on apple.com are still broken (youtube doesn't work at all and apple.com has page artifacts overlaying the video).
Comment 16 sharikov.suba 2011-04-14 12:15:10 PDT
Created attachment 89622 [details]
ClicktoFlash fullscreen issue not resolved on r83831

ClicktoFlash 2.2.4 fullscreen issue still persists.
Comment 17 Rick Baumhauer 2011-04-16 18:49:04 PDT
Probably related - when using the YouTube5 Safari extension w/Webkit nightly, the fullscreen control no longer does anything; video stays at normal size. Safari 5.0.5 handles the control properly, expanding video to fullscreen when the control is clicked.
Comment 18 Rick Baumhauer 2011-04-16 18:53:24 PDT
(In reply to comment #17)
> Probably related - when using the YouTube5 Safari extension w/Webkit nightly, the fullscreen control no longer does anything; video stays at normal size. Safari 5.0.5 handles the control properly, expanding video to fullscreen when the control is clicked.

Sorry, had comments turned off via 'Shut Up' extension, didn't realize it until my comment didn't show up. This issue has obviously been noted by others - you can take my report as confirmation that the bug still exists in Webkit Nightly.
Comment 19 sharikov.suba 2011-04-24 12:45:59 PDT
Fullscreen html5 video working with r84622 and ClicktoFlash 2.2.5
Comment 20 Rick Baumhauer 2011-04-24 12:50:56 PDT
(In reply to comment #19)
> Fullscreen html5 video working with r84622 and ClicktoFlash 2.2.5

I can confirm that full-screen HTML5 video via the YouTube5 extension is also working correctly in r84622. However, I'm suspicious of r84622's memory use - I noticed it getting sluggish after being open for only a few hours yesterday, and found that, even when I got down to only one open tab, WebKit was using 2GB+ of Real Mem.

Running Safari 5.0.5 today under similar circumstances, and it is currently around 625MB of Real Mem.
Comment 21 Marc Hoyois 2011-08-01 19:11:09 PDT
This has been fixed a long time ago. It should be closed!
Comment 22 Alexey Proskuryakov 2011-08-01 21:46:03 PDT
Thank you for following up on this!