Bug 50803

Summary: The commit-queue should file bugs about flaky tests it encounters
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: New BugsAssignee: Eric Seidel (no email) <eric>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, dbates, eric, ojan, tony
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 50853    
Attachments:
Description Flags
Patch
none
upload the right patch abarth: review+

Description Eric Seidel (no email) 2010-12-09 23:20:58 PST
The commit-queue should file bugs about flaky tests it encounters
Comment 1 Eric Seidel (no email) 2010-12-09 23:25:28 PST
Created attachment 76164 [details]
Patch
Comment 2 Eric Seidel (no email) 2010-12-09 23:26:17 PST
webkit-patch suggest-reviewers was a bit overzealous for this bug.  I think we should probably limit it to 5 CCs or something.
Comment 3 Eric Seidel (no email) 2010-12-09 23:27:54 PST
Dropping most of the CC's feel free to add yourself back of course.
Comment 4 Eric Seidel (no email) 2010-12-09 23:32:37 PST
Created attachment 76166 [details]
upload the right patch
Comment 5 Adam Barth 2010-12-09 23:59:04 PST
Comment on attachment 76166 [details]
upload the right patch

View in context: https://bugs.webkit.org/attachment.cgi?id=76166&action=review

I fear this will annoy people too much, but it seems better than our previous design.

> WebKitTools/Scripts/webkitpy/tool/bot/flakytestreporter.py:102
> +            latest_flake_message = "The %s just saw %s flake while processing patch %s on bug %s." % (self._bot_name, flaky_test, patch.id(), patch.bug_id())

You should say attachment instead of patch to get autolinking to work.
Comment 6 Daniel Bates 2010-12-10 00:04:49 PST
Comment on attachment 76166 [details]
upload the right patch

View in context: https://bugs.webkit.org/attachment.cgi?id=76166&action=review

> WebKitTools/Scripts/webkitpy/common/config/urls.py:1
> +# Copyright (c) 2010, Google Inc. All rights reserved.

Casually looked at this patch and noticed that you have an extraneous comma after 2010.
Comment 7 Eric Seidel (no email) 2010-12-10 00:31:51 PST
Committed r73692: <http://trac.webkit.org/changeset/73692>
Comment 8 Eric Seidel (no email) 2010-12-10 01:30:31 PST
Committed r73694: <http://trac.webkit.org/changeset/73694>
Comment 9 Eric Seidel (no email) 2010-12-10 12:04:47 PST
You can see the first two it's filed here:
https://bugs.webkit.org/show_bug.cgi?id=50822
https://bugs.webkit.org/show_bug.cgi?id=50823
Comment 10 Eric Seidel (no email) 2010-12-10 17:36:31 PST
*** Bug 45740 has been marked as a duplicate of this bug. ***