Bug 49394

Summary: check-webkit-style should check for meaningless variable names in function declarations.
Product: WebKit Reporter: David Levin <levin>
Component: Tools / TestsAssignee: David Levin <levin>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on: 49425, 49427, 49446, 51303, 51451, 51523    
Bug Blocks:    
Attachments:
Description Flags
Work in progress. (It is being subdivided, cleaned up, and finished as smaller patches.) none

Description David Levin 2010-11-11 11:34:00 PST
This is the style rule:
  Leave meaningless variable names out of function declarations.
  Right:
  void setCount(size_t);
  Wrong:
  void setCount(size_t count);

from http://webkit.org/coding/coding-style.html
Comment 1 David Levin 2010-11-12 05:41:38 PST
Created attachment 73730 [details]
Work in progress. (It is being subdivided, cleaned up, and finished as smaller patches.)
Comment 2 David Levin 2010-12-27 11:08:37 PST
Comment on attachment 73730 [details]
Work in progress. (It is being subdivided, cleaned up, and finished as smaller patches.)

Cleaned up. Made into smaller patches. Etc.

All done!