Bug 45089

Summary: [EFL] Remove GOwnPtr to OwnPtr in FontCacheCairo.cpp
Product: WebKit Reporter: Ryuan Choi <ryuan.choi>
Component: WebKit EFLAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: antognolli+webkit, gns, gyuyoung.kim, leandro, lucas.de.marchi
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Attachments:
Description Flags
Patch none

Description Ryuan Choi 2010-09-01 22:46:09 PDT
Because FontCacheCairo use GOwnPtr,
EWebKit can't remove glib dependency without GLIB_SUPPORT.

I suggest to change GOwnPtr to OwnPtr at below code in FontCacheCairo.

    GOwnPtr<FcPattern> pattern(FcPatternCreate());
    if (!FcPatternAddString(pattern.get(), FC_FAMILY, reinterpret_cast<const FcChar8*>(fcfamily)))
        return 0;

    GOwnPtr<FcObjectSet> objectSet(FcObjectSetCreate());
    if (!FcObjectSetAdd(objectSet.get(), FC_FAMILY))
        return 0;

    GOwnPtr<FcFontSet> fontSet(FcFontList(0, pattern.get(), objectSet.get()));
Comment 1 Ryuan Choi 2010-09-01 22:58:26 PDT
Created attachment 66335 [details]
Patch
Comment 2 Rafael Antognolli 2010-09-02 09:18:56 PDT
Hi Ryuan,

I think you sent exactly the same patch that I sent in bug 45053 :P
Comment 3 Ryuan Choi 2010-09-05 04:10:23 PDT
yes, Sorry I didn't see :)

*** This bug has been marked as a duplicate of bug 45053 ***
Comment 4 Martin Robinson 2010-09-15 11:58:52 PDT
Comment on attachment 66335 [details]
Patch

Clearing flags, as this has already landed elsewhere.