Bug 40123

Summary: REGRESSION(r60614): It made fast/dom/Window/window-postmessage-clone.html fail on Mac bots (Requested by Ossy on #webkit).
Product: WebKit Reporter: WebKit Review Bot <webkit.review.bot>
Component: New BugsAssignee: WebKit Review Bot <webkit.review.bot>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, eric, hausmann, ossy, rniwa
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 39757    
Attachments:
Description Flags
ROLLOUT of r60614
none
Archive of layout-test-results from webkit-cq-01
none
Archive of layout-test-results from webkit-cq-01 none

Description WebKit Review Bot 2010-06-03 08:48:41 PDT
http://trac.webkit.org/changeset/60614 broke the build:
It made fast/dom/Window/window-postmessage-clone.html fail on Mac bots (Requested by Ossy on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2010-06-03 08:48:53 PDT
Created attachment 57773 [details]
ROLLOUT of r60614

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Csaba Osztrogonác 2010-06-03 09:27:45 PDT
Landed manually, because commit queue can't do it:
#  Unable to successfully build and test  3 minutes ago
# Patch 57773 from bug 40123: Landing rollout patch 11 minutes ago 

Eric, have you got any idea what was the problem?

http://trac.webkit.org/changeset/60624
Comment 3 Csaba Osztrogonác 2010-06-03 09:30:36 PDT
*** Bug 40125 has been marked as a duplicate of this bug. ***
Comment 4 WebKit Commit Bot 2013-05-29 11:36:14 PDT
The commit-queue just saw fast/dom/Window/window-postmessage-clone.html flake (text diff) while processing attachment 203217 [details] on bug 116954.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.8.3
Comment 5 WebKit Commit Bot 2013-05-29 11:36:17 PDT
Created attachment 203249 [details]
Archive of layout-test-results from webkit-cq-01
Comment 6 Alexey Proskuryakov 2013-05-29 22:36:21 PDT
> The commit-queue just saw fast/dom/Window/window-postmessage-clone.html flake (text diff) while processing attachment 203217 [details] on bug 116954.

Seems wrong to re-open a three year old bug because of this. Let's see if commit queue does that again.
Comment 7 WebKit Commit Bot 2013-06-11 01:46:33 PDT
The commit-queue just saw fast/dom/Window/window-postmessage-clone.html flake (text diff) while processing attachment 204297 [details] on bug 117295.
Bot: webkit-cq-01  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.8.3
Comment 8 WebKit Commit Bot 2013-06-11 01:46:37 PDT
Created attachment 204327 [details]
Archive of layout-test-results from webkit-cq-01
Comment 9 Csaba Osztrogonác 2013-06-11 01:51:37 PDT
One more unnecessary reopen. :-/
I filed a new bug report for it: https://bugs.webkit.org/show_bug.cgi?id=117503