Bug 37993

Summary: Assertion failure in AnimationBase::updateStateMachine() coming out of paused state
Product: WebKit Reporter: Chris Marrin <cmarrin>
Component: CSSAssignee: Chris Marrin <cmarrin>
Status: RESOLVED FIXED    
Severity: Normal CC: joepeck, ossy
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on: 42821    
Bug Blocks:    
Attachments:
Description Flags
Patch simon.fraser: review+

Description Chris Marrin 2010-04-22 10:29:33 PDT
This is rare and hard to reproduce, but if you go into pause state when in the AnimationStateStartWaitStyleAvailable, the state of m_pauseTime is incorrect, leading to an assert when coming out of pause state.
Comment 1 Chris Marrin 2010-07-21 11:44:10 PDT
It's actually easy to reproduce, but you have to use the "pause API" (a feature available in LayoutTests) to get it to happen. You simply run a debug build, start a transition and then pause and unpause. The assert is usually hit. I will try to post a test.
Comment 2 Chris Marrin 2010-07-21 14:49:30 PDT
It's actually easy to reproduce, but you have to use the "pause API" (a feature available in LayoutTests) to get it to happen. You simply run a debug build, start a transition and then pause and unpause. The assert is usually hit. I will try to post a test.
Comment 3 Chris Marrin 2010-07-21 14:51:03 PDT
Created attachment 62236 [details]
Patch
Comment 4 Simon Fraser (smfr) 2010-07-21 14:56:02 PDT
Comment on attachment 62236 [details]
Patch

> Index: WebCore/ChangeLog
> ===================================================================

> +        https://bugs.webkit.org/show_bug.cgi?id=37993

The bug title should be on the line above the url ("webkit-patch upload" will do this for you).

r=me
Comment 5 Chris Marrin 2010-07-21 16:16:59 PDT
Patch landed in http://trac.webkit.org/changeset/63862
Comment 6 Csaba Osztrogon√°c 2010-07-22 06:12:25 PDT
After this patch animations/play-state.html is flakey on Qt bot:
http://build.webkit.org/results/Qt%20Linux%20Release/r63884%20%2815890%29/animations/play-state-pretty-diff.html

Could you check what the problem is?