Bug 35726

Summary: Remove orphaned #ifdef WTF_USE_GLIB_ICU_UNICODE_HYBRID
Product: WebKit Reporter: Dominik Röttsches (drott) <d-r>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Minor CC: commit-queue, fridrich.strba
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
removing the orphaned condition
none
Patch to remove all orphaned occurences of GLIB_ICU_UNICODE_HYBRID none

Description Dominik Röttsches (drott) 2010-03-04 01:14:42 PST
WTF_USE_GLIB_ICU_UNICODE_HYBRID is not needed/used anymore. The leftover usage in ThreadGlobalData.h needs to go away.
Comment 1 Dominik Röttsches (drott) 2010-03-04 01:22:09 PST
Created attachment 49996 [details]
removing the orphaned condition
Comment 2 Fridrich Strba 2010-03-04 01:34:28 PST
There is one more instance of that define in that file and then there is the define in GNUMakefile.am
Comment 3 Fridrich Strba 2010-03-04 05:48:44 PST
Created attachment 50007 [details]
Patch to remove all orphaned occurences of GLIB_ICU_UNICODE_HYBRID
Comment 4 Fridrich Strba 2010-03-04 05:52:26 PST
*** Bug 35704 has been marked as a duplicate of this bug. ***
Comment 5 Fridrich Strba 2010-03-04 05:53:17 PST
OK, I went through the sources and removed the orphaned mentions.
Comment 6 Holger Freyther 2010-03-04 05:56:15 PST
Comment on attachment 50007 [details]
Patch to remove all orphaned occurences of GLIB_ICU_UNICODE_HYBRID

Seems to be fine.
Comment 7 WebKit Commit Bot 2010-03-04 07:03:21 PST
Comment on attachment 50007 [details]
Patch to remove all orphaned occurences of GLIB_ICU_UNICODE_HYBRID

Clearing flags on attachment: 50007

Committed r55524: <http://trac.webkit.org/changeset/55524>
Comment 8 WebKit Commit Bot 2010-03-04 07:03:26 PST
All reviewed patches have been landed.  Closing bug.