Summary: | [Qt] QScriptValue autotests | ||||||
---|---|---|---|---|---|---|---|
Product: | WebKit | Reporter: | Jędrzej Nowacki <jedrzej.nowacki> | ||||
Component: | JavaScriptCore | Assignee: | Jędrzej Nowacki <jedrzej.nowacki> | ||||
Status: | RESOLVED FIXED | ||||||
Severity: | Normal | CC: | commit-queue, hausmann, webkit.review.bot | ||||
Priority: | P2 | Keywords: | Qt | ||||
Version: | 528+ (Nightly build) | ||||||
Hardware: | All | ||||||
OS: | All | ||||||
Bug Depends on: | |||||||
Bug Blocks: | 31863, 34575 | ||||||
Attachments: |
|
Description
Jędrzej Nowacki
2010-02-03 08:49:06 PST
Created attachment 48042 [details]
Autotests v1
I suppose that style bot will warn about naming issues (an underscore inside methods names). I can change it, but I found that the naming style is coherent with Qt's autotest framework which use _data methods for a similar use case.
Attachment 48042 [details] did not pass style-queue:
Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
Last 3072 characters of output:
med. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:98: isFunction_makeData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:99: isFunction_test is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:101: isNull_initData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:102: isNull_makeData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:103: isNull_test is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:105: isObject_initData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:106: isObject_makeData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:107: isObject_test is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:109: isString_initData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:110: isString_makeData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:111: isString_test is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:113: isUndefined_initData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:114: isUndefined_makeData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:115: isUndefined_test is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:117: isValid_initData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:118: isValid_makeData is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
JavaScriptCore/qt/tests/qscriptvalue/tst_qscriptvalue.h:119: isValid_test is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4]
Total errors found: 38
If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 48042 [details] Autotests v1 > +void tst_QScriptValue::initScriptValues() > +{ > + m_values.clear(); > + if (engine) > + delete engine; The if check is not necessary :) Please also file bug reports against the style checker. Either we need to exclude the files from the style check or perhaps it can be fixed to ignore that particular rule in that file. Comment on attachment 48042 [details] Autotests v1 Clearing flags on attachment: 48042 Committed r54340: <http://trac.webkit.org/changeset/54340> All reviewed patches have been landed. Closing bug. |