Bug 26487

Summary: WebKit Normalizing Path Segments
Product: WebKit Reporter: Jeff Schiller <jeffschiller>
Component: SVGAssignee: Nobody <webkit-unassigned>
Status: RESOLVED INVALID    
Severity: Normal CC: adeveria, davinci, gavin, juraj.sukop, krit
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Macintosh   
OS: OS X 10.5   
URL: webkit-unassigned@lists.webkit.org
Bug Depends on: 10827    
Bug Blocks:    
Attachments:
Description Flags
Test case revealing the problem. none

Description Jeff Schiller 2009-06-17 11:20:25 PDT
Attaching a test case which reveals that WebKit normalizes path segments (all straight segments become PATHSEG_LINETO_ABS).  It's my understanding based on http://www.w3.org/TR/SVG11/paths.html#InterfaceSVGAnimatedPathData that only normalizedPathSegList should have normalized segments and that pathSegList should contain the segments as they were written.
Comment 1 Jeff Schiller 2009-06-17 11:21:06 PDT
Created attachment 31427 [details]
Test case revealing the problem.

Mozilla and Opera both pass this test.
Comment 2 Cameron McCormack 2009-09-08 01:18:03 PDT
*** Bug 25968 has been marked as a duplicate of this bug. ***
Comment 3 Alexis Deveria 2009-10-08 10:47:49 PDT
*** Bug 30222 has been marked as a duplicate of this bug. ***
Comment 4 David Yonge-Mallo 2010-03-25 07:46:40 PDT
Fixing this bug would make bug 30219 much easier to fix properly as well.
Comment 5 Gavin Kistner 2012-03-12 19:11:31 PDT
The test case works correctly in Safari 5.1.3. I don't know when differentiated path segment types were added to the pathSegList, but they are there now (and have been for some time). I believe that this bug is fixed and should be closed.
Comment 6 Dirk Schulze 2016-10-12 05:27:08 PDT
normalized path methods were removed from SVG2