Bug 25968 - SVG path command 'Q' gets parsed as 'C'
Summary: SVG path command 'Q' gets parsed as 'C'
Status: RESOLVED DUPLICATE of bug 26487
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-22 13:21 PDT by Juraj Sukop
Modified: 2009-09-08 01:18 PDT (History)
1 user (show)

See Also:


Attachments
Testcase (777 bytes, application/xhtml+xml)
2009-05-22 13:21 PDT, Juraj Sukop
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juraj Sukop 2009-05-22 13:21:00 PDT
A quadratic Bezier path segment of an SVG path gets replaced by a cubic segment.

Say, the 2nd segment of
<path d="M100,100Q900,500 100,900L100,100z" />
appears to be of cubic type (C), instead of quadratic one (Q).

Please, see the attached test case.
Comment 1 Juraj Sukop 2009-05-22 13:21:34 PDT
Created attachment 30591 [details]
Testcase
Comment 2 Cameron McCormack 2009-09-08 01:18:03 PDT

*** This bug has been marked as a duplicate of bug 26487 ***