Bug 244324

Summary: iOS 16 public beta 7 (20A5356a) Safari cannot display some AVIF image
Product: WebKit Reporter: Tetsuharu Ohzeki [UTC+9] <tetsuharu.ohzeki>
Component: ImagesAssignee: Said Abou-Hallawa <sabouhallawa>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: mmaxfield, sabouhallawa, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: iPhone / iPad   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 241904    
Attachments:
Description Flags
https://libre-software.net/wp-content/uploads/sites/3/AVIF/AVIF%20Test%20picture%20%28JPEG%20converted%20to%20AVIF%20with%20Convertio%29.avif none

Description Tetsuharu Ohzeki [UTC+9] 2022-08-25 00:00:33 PDT
Created attachment 461854 [details]
https://libre-software.net/wp-content/uploads/sites/3/AVIF/AVIF%20Test%20picture%20%28JPEG%20converted%20to%20AVIF%20with%20Convertio%29.avif

## Abstraction

iOS 16.0 public beta 7's Safari cannot display an AVIF image in https://libre-software.net/avif-test/


## Environment

- iOS 16.0 public beta 7 (20A5356a)


## Steps to Reproduce

- Open https://libre-software.net/avif-test/
- ...or open the attached file in Safari

## Actual Result

1. Safari cannot display it.
2. But iOS' Files.app can display the preview for it if I save this avif image to the local.



## Expected Result

We should display it.

- Firefox 104
- Chrome 104

can display it.
Comment 1 Radar WebKit Bug Importer 2022-08-25 09:02:39 PDT
<rdar://problem/99140401>
Comment 2 Sam Sneddon [:gsnedders] 2022-08-25 09:54:24 PDT
Given Files.app works fine, I suspect this is something failing in our handling of <picture>.
Comment 3 Said Abou-Hallawa 2022-08-25 11:21:12 PDT
The inspector tool in the Preview app says the attached image is a HEIF image. So this is a dupe of bug 244103.

*** This bug has been marked as a duplicate of bug 244103 ***