Bug 204701

Summary: Use default implementation for JSVALUE64 with GCC on unknown platform.
Product: WebKit Reporter: Eike Rathke <erack>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: berto, commit-queue, ews-watchlist, jbedard, jlewis3, keith_miller, mark.lam, msaboff, sbarati, simon.fraser, tsavell, tzagallo, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description Eike Rathke 2019-11-29 06:54:00 PST
Use default implementation for JSVALUE64 with GCC on unknown platform.
Comment 1 Eike Rathke 2019-11-29 06:57:01 PST
Created attachment 384504 [details]
Patch
Comment 2 Eike Rathke 2019-11-29 07:02:43 PST
Created attachment 384505 [details]
Patch
Comment 3 Eike Rathke 2019-11-29 07:06:19 PST
Grml.. webkit-patch insists on including it's on modification to force python2 even if already committed. I'll resubmit a manual patch.
Comment 4 Eike Rathke 2019-11-29 07:08:58 PST
Created attachment 384506 [details]
Patch
Comment 5 Eike Rathke 2019-11-29 07:35:31 PST
Note: the style checker seems to be wrong in its analysis.
Comment 6 Saam Barati 2019-11-29 10:13:37 PST
Comment on attachment 384506 [details]
Patch

r=me
Comment 7 WebKit Commit Bot 2019-11-29 11:03:42 PST
Comment on attachment 384506 [details]
Patch

Clearing flags on attachment: 384506

Committed r252949: <https://trac.webkit.org/changeset/252949>
Comment 8 WebKit Commit Bot 2019-11-29 11:03:44 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Radar WebKit Bug Importer 2019-11-29 11:04:19 PST
<rdar://problem/57534280>
Comment 10 Alberto Garcia 2019-12-01 10:18:49 PST
*** Bug 204643 has been marked as a duplicate of this bug. ***
Comment 11 Jonathan Bedard 2019-12-17 08:23:29 PST
I think this broke Windows jsc tests:
https://build.webkit.org/builders/Apple%20Win%2010%20Debug%20%28Tests%29?numbuilds=200

We don't have a super great range, unfortunately, since the build was broken, but this its the only commit which touched JSC stuff in https://results.webkit.org/commits?before_id=252951&after_id=252943
Comment 12 Eike Rathke 2019-12-18 05:24:00 PST
Only if the Windows build suddenly uses GCC on a non-x86-64 platform..
Comment 13 Jonathan Bedard 2019-12-18 07:52:08 PST
(In reply to Eike Rathke from comment #12)
> Only if the Windows build suddenly uses GCC on a non-x86-64 platform..

That's what Saam said. Mark is looking into it (or at least was yesterday), even taking a deeper dive into the commits in our regression range, I don't see another commit that even touches JSC.