Bug 203847

Summary: Master bug: Motion path/Offset spec
Product: WebKit Reporter: Dirk Schulze <krit>
Component: CSSAssignee: Kiet Ho <tuankiet65>
Status: NEW ---    
Severity: Normal CC: boris.chiou, dino, gerard, graouts, mfishe, simon.fraser, tuankiet65, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 233340, 235818, 240270, 240272, 242183, 203848, 203967, 231195, 231491, 231801, 232752, 232760, 233109, 233144, 233153, 233344, 233382, 235786, 235817, 238423, 240259, 240474, 240594, 240599    
Bug Blocks:    

Description Dirk Schulze 2019-11-05 05:35:15 PST
The master bug for implementing the Motion Path / Offset spec. https://drafts.fxtf.org/motion-1/

Goal is to get WebCore in parity with Blink's and Gecko's implementation initially. That means support for:
* offset-distance
* offset-rotate
* offset-path (only none | path())
* offset shorthand
Comment 1 Dirk Schulze 2019-11-05 05:42:04 PST
The implementation happens behind the runtime flag cssOffset
Comment 2 Simon Fraser (smfr) 2019-11-05 13:39:12 PST
(In reply to Dirk Schulze from comment #1)
> The implementation happens behind the runtime flag cssOffset

Let's align the flag with the spec shortname.
Comment 3 Dirk Schulze 2019-11-05 16:29:22 PST
(In reply to Simon Fraser (smfr) from comment #2)
> (In reply to Dirk Schulze from comment #1)
> > The implementation happens behind the runtime flag cssOffset
> 
> Let's align the flag with the spec shortname.

I wonder if the CSS WG should rather rename the spec with its short name from motion to offset just like it renamed the properties. IMO it was an oversight and should be corrected to avoid confusions in the future.

However, I don’t mind to rename it here but would still ask the WG to rename.

To consider: All CSS properties (like logical units) are prefixed with css it seems.
Comment 4 Simon Fraser (smfr) 2019-11-05 17:05:38 PST
"offset" sounds way too generic.
Comment 5 Dirk Schulze 2019-11-06 12:13:46 PST
Changed the runtime flag name to "motion" with the first patch in https://bugs.webkit.org/show_bug.cgi?id=203848 as it is the shorthand of the spec.
Comment 6 Radar WebKit Bug Importer 2019-11-15 13:41:22 PST
<rdar://problem/57238772>
Comment 7 Kiet Ho 2021-10-21 15:28:23 PDT
*** Bug 139127 has been marked as a duplicate of this bug. ***