Bug 192064

Summary: Flaky Test: inspector/dom/breakpoint-for-event-listener.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: drousso, lforschler, ryanhaddad, tsavell
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 50856    
Attachments:
Description Flags
Archive of layout-test-results from webkit-cq-03 none

Description WebKit Commit Bot 2018-11-27 18:38:43 PST
This is an automatically generated bug from the commit-queue.
inspector/dom/breakpoint-for-event-listener.html has been flaky on the commit-queue.

inspector/dom/breakpoint-for-event-listener.html was authored by drousso@apple.com.
https://trac.webkit.org/browser/trunk/LayoutTests/inspector/dom/breakpoint-for-event-listener.html

The commit-queue just saw inspector/dom/breakpoint-for-event-listener.html flake (DumpRenderTree crashed) while processing attachment 355832 [details] on bug 192060.
Bot: webkit-cq-03  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-11-27 18:38:44 PST
Created attachment 355835 [details]
Archive of layout-test-results from webkit-cq-03
Comment 2 Ryan Haddad 2018-11-28 09:53:24 PST
Thread 34 Crashed:: DFG Worklist Worker Thread
0   com.apple.JavaScriptCore      	0x00000001053daf15 JSC::speculationFromValue(JSC::JSValue) + 213 (SpeculatedType.cpp:477)
1   com.apple.JavaScriptCore      	0x00000001053aec16 JSC::CodeBlock::valueProfilePredictionForBytecodeOffset(JSC::ConcurrentJSLocker const&, int) + 38 (SpeculatedType.h:473)
2   com.apple.JavaScriptCore      	0x00000001054b4617 JSC::DFG::ByteCodeParser::getPredictionWithoutOSRExit(unsigned int) + 343 (DFGByteCodeParser.cpp:876)
3   com.apple.JavaScriptCore      	0x00000001054a53a9 JSC::DFG::ByteCodeParser::Terminality JSC::DFG::ByteCodeParser::handleCall<JSC::OpTailCall>(JSC::Instruction const*, JSC::DFG::NodeType, JSC::CallMode) + 537 (DFGByteCodeParser.cpp:889)
4   com.apple.JavaScriptCore      	0x000000010549362e JSC::DFG::ByteCodeParser::parseBlock(unsigned int) + 3118 (Instruction.h:45)
5   com.apple.JavaScriptCore      	0x00000001054a86ea JSC::DFG::ByteCodeParser::parseCodeBlock() + 810 (DFGByteCodeParser.cpp:7037)
6   com.apple.JavaScriptCore      	0x0000000105487983 JSC::DFG::ByteCodeParser::handleCallVariant(JSC::DFG::Node*, JSC::VirtualRegister, JSC::CallVariant, int, JSC::VirtualRegister, int, unsigned int, JSC::InlineCallFrame::Kind, unsigned long long, unsigned int&, JSC::DFG::BasicBlock*, bool) + 5203 (Vector.h:1114)
7   com.apple.JavaScriptCore      	0x00000001054852ac JSC::DFG::ByteCodeParser::handleInlining(JSC::DFG::Node*, JSC::VirtualRegister, JSC::CallLinkStatus const&, int, JSC::VirtualRegister, int, unsigned int, JSC::DFG::NodeType, JSC::InlineCallFrame::Kind, unsigned long long) + 188 (DFGByteCodeParser.cpp:1916)
8   com.apple.JavaScriptCore      	0x00000001054850b2 JSC::DFG::ByteCodeParser::handleCall(JSC::VirtualRegister, JSC::DFG::NodeType, JSC::InlineCallFrame::Kind, unsigned int, JSC::DFG::Node*, int, int, JSC::CallLinkStatus, unsigned long long) + 386 (DFGByteCodeParser.cpp:1262)
9   com.apple.JavaScriptCore      	0x00000001054a50fc JSC::DFG::ByteCodeParser::Terminality JSC::DFG::ByteCodeParser::handleCall<JSC::OpCall>(JSC::Instruction const*, JSC::DFG::NodeType, JSC::CallMode) + 604 (DFGByteCodeParser.cpp:1235)
10  com.apple.JavaScriptCore      	0x0000000105493b9c JSC::DFG::ByteCodeParser::parseBlock(unsigned int) + 4508 (Instruction.h:45)
11  com.apple.JavaScriptCore      	0x00000001054a86ea JSC::DFG::ByteCodeParser::parseCodeBlock() + 810 (DFGByteCodeParser.cpp:7037)
12  com.apple.JavaScriptCore      	0x00000001054a8a83 JSC::DFG::ByteCodeParser::parse() + 83 (DFGByteCodeParser.cpp:6852)
13  com.apple.JavaScriptCore      	0x00000001054a9be8 JSC::DFG::parse(JSC::DFG::Graph&) + 392 (DFGByteCodeParser.cpp:93)
14  com.apple.JavaScriptCore      	0x000000010560dde2 JSC::DFG::Plan::compileInThreadImpl() + 338 (DFGPlan.cpp:251)
15  com.apple.JavaScriptCore      	0x000000010560d58b JSC::DFG::Plan::compileInThread(JSC::DFG::ThreadData*) + 619 (DFGPlan.cpp:188)
16  com.apple.JavaScriptCore      	0x000000010565af95 JSC::DFG::Worklist::ThreadBody::work() + 277 (DumbPtrTraits.h:41)
17  com.apple.JavaScriptCore      	0x0000000104faa9fe WTF::Function<void ()>::CallableWrapper<WTF::AutomaticThread::start(WTF::AbstractLocker const&)::$_0>::call() + 334 (AutomaticThread.cpp:224)
18  com.apple.JavaScriptCore      	0x0000000104fec044 WTF::Thread::entryPoint(WTF::Thread::NewThreadContext*) + 212 (memory:2735)
19  com.apple.JavaScriptCore      	0x0000000104fedbe9 WTF::wtfThreadEntryPoint(void*) + 9 (ThreadingPthreads.cpp:203)
20  libsystem_pthread.dylib       	0x00007fffb76ea93b _pthread_body + 180
21  libsystem_pthread.dylib       	0x00007fffb76ea887 _pthread_start + 286
22  libsystem_pthread.dylib       	0x00007fffb76ea08d thread_start + 13
Comment 3 Alexey Proskuryakov 2018-12-01 16:05:20 PST

*** This bug has been marked as a duplicate of bug 192050 ***