Bug 170953

Summary: [mac-wk1 Debug] LayoutTest http/tests/inspector/network/resource-sizes-network.html is a flaky failure
Product: WebKit Reporter: Ryan Haddad <ryanhaddad>
Component: Web InspectorAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, inspector-bugzilla-changes, joepeck
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=170971
Attachments:
Description Flags
[PATCH] Proposed Fix
none
[PATCH] Proposed Fix none

Description Ryan Haddad 2017-04-18 10:22:14 PDT
LayoutTest http/tests/inspector/network/resource-sizes-network.html is a flaky failure

https://build.webkit.org/results/Apple%20El%20Capitan%20Debug%20WK1%20(Tests)/r215460%20(622)/results.html

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2Finspector%2Fnetwork%2Fresource-sizes-network.html

--- /Volumes/Data/slave/elcapitan-debug-tests-wk1/build/layout-test-results/http/tests/inspector/network/resource-sizes-network-expected.txt
+++ /Volumes/Data/slave/elcapitan-debug-tests-wk1/build/layout-test-results/http/tests/inspector/network/resource-sizes-network-actual.txt
@@ -140,7 +140,9 @@
 PASS: responseSource should be Symbol(network).
 PASS: estimatedNetworkEncodedSize should be exactly 28 bytes.
 PASS: estimatedTotalTransferSize should be >= (encoded body size + headers).
-PASS: size should be exactly 28 bytes.
+FAIL: size should be exactly 28 bytes.
+    Expected: 28
+    Actual: NaN
 FAIL: networkEncodedSize should be exactly 28 bytes.
     Expected: 28
     Actual: NaN
Comment 1 Joseph Pecoraro 2017-04-18 13:27:37 PDT
Arg, we should just mark this test as flakey on WebKit 1 then. (mac-wk1).

I should be able to do that.
Comment 2 Joseph Pecoraro 2017-04-18 13:38:16 PDT
Marked as flakey on WebKit 1:
https://trac.webkit.org/changeset/215478/webkit
Comment 3 Ryan Haddad 2017-04-20 09:49:25 PDT
Just saw this test fail on mac-wk2: https://build.webkit.org/builders/Apple%20El%20Capitan%20Debug%20WK2%20(Tests)/builds/629
Comment 4 Joseph Pecoraro 2017-04-20 11:41:17 PDT
Okay I'll take a look today to see if I can unflake this. I think I just need to wait slightly longer for the load to complete in fetch.
Comment 5 Joseph Pecoraro 2017-04-25 20:22:32 PDT
Created attachment 308198 [details]
[PATCH] Proposed Fix

I was able to occasionally see failures on my laptop. With this change I didn't see such failures. On my Mac Pro I never saw failures, so this is still somewhat speculative.
Comment 6 Joseph Pecoraro 2017-04-25 20:24:35 PDT
Comment on attachment 308198 [details]
[PATCH] Proposed Fix

Err, I have to update to unskip the test that has since been marked flakey.
Comment 7 Joseph Pecoraro 2017-04-25 20:47:59 PDT
*** Bug 170971 has been marked as a duplicate of this bug. ***
Comment 8 Joseph Pecoraro 2017-04-25 20:50:25 PDT
Created attachment 308204 [details]
[PATCH] Proposed Fix
Comment 9 BJ Burg 2017-04-25 23:09:16 PDT
Comment on attachment 308204 [details]
[PATCH] Proposed Fix

r=me
Comment 10 WebKit Commit Bot 2017-04-25 23:38:41 PDT
Comment on attachment 308204 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 308204

Committed r215794: <http://trac.webkit.org/changeset/215794>
Comment 11 WebKit Commit Bot 2017-04-25 23:38:42 PDT
All reviewed patches have been landed.  Closing bug.