Bug 161100

Summary: Typed arrays should use MarkedSpace instead of CopiedSpace
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, keith_miller, mark.lam, msaboff, ryanhaddad, sbarati
Priority: P2    
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on: 161646    
Bug Blocks: 159658    
Attachments:
Description Flags
the patch
ggaren: review+
patch for landing
buildbot: commit-queue-
Archive of layout-test-results from ews114 for mac-yosemite
none
patch for landing
none
patch for relanding none

Description Filip Pizlo 2016-08-23 13:19:53 PDT
Patch forthcoming.
Comment 1 Filip Pizlo 2016-08-23 13:43:12 PDT
*** Bug 125425 has been marked as a duplicate of this bug. ***
Comment 2 Filip Pizlo 2016-08-23 15:22:33 PDT
Created attachment 286788 [details]
the patch
Comment 3 Geoffrey Garen 2016-08-23 15:26:02 PDT
Comment on attachment 286788 [details]
the patch

r=me
Comment 4 Filip Pizlo 2016-08-23 15:34:44 PDT
Created attachment 286792 [details]
patch for landing

I fixed some goofs.
Comment 5 Build Bot 2016-08-23 19:53:29 PDT
Comment on attachment 286792 [details]
patch for landing

Attachment 286792 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/1931454

New failing tests:
fast/canvas/webgl/premultiplyalpha-test.html
webgl/1.0.3/conformance/extensions/oes-texture-float-linear.html
imported/w3c/WebCryptoAPI/digest/test_digest.html
webgl/1.0.2/conformance/uniforms/uniform-default-values.html
fast/canvas/webgl/drawingbuffer-test.html
webgl/1.0.2/conformance/textures/texture-size-cube-maps.html
fast/canvas/webgl/uninitialized-test.html
webgl/1.0.2/conformance/misc/uninitialized-test.html
webgl/1.0.2/conformance/textures/texture-size.html
webgl/1.0.2/conformance/canvas/drawingbuffer-hd-dpi-test.html
Comment 6 Build Bot 2016-08-23 19:53:33 PDT
Created attachment 286825 [details]
Archive of layout-test-results from ews114 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews114  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 7 Filip Pizlo 2016-09-06 09:52:46 PDT
Created attachment 288031 [details]
patch for landing
Comment 8 WebKit Commit Bot 2016-09-06 09:54:58 PDT
Attachment 288031 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:46:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:46:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:47:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:48:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:49:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:50:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
Total errors found: 6 in 12 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 9 Filip Pizlo 2016-09-06 11:22:03 PDT
Landed in https://trac.webkit.org/changeset/205494
Comment 10 Ryan Haddad 2016-09-06 13:49:04 PDT
This change appears to have broken the Windows build:

https://build.webkit.org/builders/Apple%20Win%20Release%20%28Build%29/builds/80295
Comment 11 WebKit Commit Bot 2016-09-06 14:42:41 PDT
Re-opened since this is blocked by bug 161646
Comment 12 Filip Pizlo 2016-09-07 17:02:09 PDT
Created attachment 288207 [details]
patch for relanding
Comment 13 WebKit Commit Bot 2016-09-07 17:04:33 PDT
Attachment 288207 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:46:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:46:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:47:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:48:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:49:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
ERROR: Source/JavaScriptCore/runtime/JSArrayBufferView.cpp:50:  Wrong number of spaces before statement. (expected: 8)  [whitespace/indent] [4]
Total errors found: 6 in 12 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 14 Filip Pizlo 2016-09-08 12:03:32 PDT
Relanded in https://trac.webkit.org/changeset/205648