Bug 156679

Summary: Trunk r198947 (Compile DumpRenderTree with CMake on Mac) causes build failures on OSX
Product: WebKit Reporter: Jeremy Huddleston Sequoia <jeremyhu>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=156088
Bug Depends on:    
Bug Blocks: 126492    
Attachments:
Description Flags
0001-Fix-incorrect-assumption-that-APPLE-implies-Mac
none
0001-Fix-incorrect-assumption-that-APPLE-implies-Mac none

Description Jeremy Huddleston Sequoia 2016-04-17 13:35:40 PDT
The changes in r198947 for https://bugs.webkit.org/show_bug.cgi?id=156088 introduced build failures on OSX.

The changes in r198947 assume that APPLE implies bundled framework.  This certainly doesn't work for the GTK build and I suspect also fails for QT.

I believe you should be using (PORT STREQUAL "Mac") instead.
Comment 1 Jeremy Huddleston Sequoia 2016-04-17 14:02:30 PDT
Created attachment 276597 [details]
0001-Fix-incorrect-assumption-that-APPLE-implies-Mac

Presumptive fix.  Testing it now.
Comment 2 Jeremy Huddleston Sequoia 2016-04-17 14:44:07 PDT
This change fixes the issue in WebKit, but looks like more recent changes on master caused it to not apply cleanly.
Comment 3 Jeremy Huddleston Sequoia 2016-04-17 14:50:38 PDT
Created attachment 276598 [details]
0001-Fix-incorrect-assumption-that-APPLE-implies-Mac
Comment 4 Jeremy Huddleston Sequoia 2016-04-17 14:54:26 PDT
*** Bug 156616 has been marked as a duplicate of this bug. ***
Comment 5 WebKit Commit Bot 2016-04-18 01:09:42 PDT
Comment on attachment 276598 [details]
0001-Fix-incorrect-assumption-that-APPLE-implies-Mac

Clearing flags on attachment: 276598

Committed r199656: <http://trac.webkit.org/changeset/199656>
Comment 6 WebKit Commit Bot 2016-04-18 01:09:45 PDT
All reviewed patches have been landed.  Closing bug.