Bug 153036

Summary: Web Inspector: Timelines UI redesign: remove navigation sidebar
Product: WebKit Reporter: Matt Baker <mattbaker>
Component: Web InspectorAssignee: Matt Baker <mattbaker>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, graouts, joepeck, mattbaker, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on: 153035, 153032, 153033, 153034, 153532, 154954, 155318    
Bug Blocks: 154920, 154924    
Attachments:
Description Flags
[Patch] Proposed Fix none

Description Matt Baker 2016-01-12 12:51:05 PST
* SUMMARY
Remove the navigation sidebar from the Timelines tab.
Comment 1 Radar WebKit Bug Importer 2016-01-14 14:36:04 PST
<rdar://problem/24195627>
Comment 2 Nikita Vasilyev 2016-01-14 17:17:17 PST
Are there any screenshots? At this point, it's hard for
me to picture how would it work without the sidebar.
Comment 3 Matt Baker 2016-01-15 13:42:06 PST
(In reply to comment #2)
> Are there any screenshots? At this point, it's hard for
> me to picture how would it work without the sidebar.

It won't work, until the issues this bug depends on are complete. I'll put up a screen shot soon.
Comment 4 Matt Baker 2016-03-10 15:12:32 PST
Created attachment 273633 [details]
[Patch] Proposed Fix
Comment 5 WebKit Commit Bot 2016-03-10 16:49:05 PST
Comment on attachment 273633 [details]
[Patch] Proposed Fix

Clearing flags on attachment: 273633

Committed r197974: <http://trac.webkit.org/changeset/197974>
Comment 6 WebKit Commit Bot 2016-03-10 16:49:08 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Timothy Hatcher 2016-03-10 16:59:02 PST
*** Bug 154973 has been marked as a duplicate of this bug. ***
Comment 8 Joseph Pecoraro 2016-03-14 13:21:21 PDT
Looks like this didn't handle the HeapAllocationsTimelineView.