Bug 142177

Summary: Rename SOFT_LINK_{CONSTANT,FUNCTION}_{HEADER,SOURCE} to SOFT_LINK_{CONSTANT,FUNCTION}_FOR_{HEADER,SOURCE}
Product: WebKit Reporter: David Kilzer (:ddkilzer) <ddkilzer>
Component: WebCore Misc.Assignee: David Kilzer (:ddkilzer) <ddkilzer>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, ap, bfulgham, commit-queue, ddkilzer
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=141816
https://bugs.webkit.org/show_bug.cgi?id=142434
Bug Depends on:    
Bug Blocks: 141625    
Attachments:
Description Flags
Patch v1 none

Description David Kilzer (:ddkilzer) 2015-03-02 10:01:33 PST
In Bug 141816 Comment #17, Alexey suggests renaming the SOFT_LINK macros to include a preposition so they're more readable.

After leaving this code for a few days and coming back, I'm inclined to agree:

SOFT_LINK_{CONSTANT,FUNCTION}_HEADER() => SOFT_LINK_{CONSTANT,FUNCTION}_FOR_HEADER()
SOFT_LINK_{CONSTANT,FUNCTION}_SOURCE() => SOFT_LINK_{CONSTANT,FUNCTION}_FOR_SOURCE()

In bug 141816, Alexey suggested "CPP" instead of "SOURCE", although I find "CPP" more ambiguous:  "C Pre-Processor", which would be the same as "HEADER" vs. "C-Plus-Plus [Source]".

I suppose if we used "CPP" instead of "SOURCE", we should use "H" instead of "HEADER" to be consistent, but that doesn't seem like an improvement either.

Will follow up with Alexey in person.
Comment 1 David Kilzer (:ddkilzer) 2015-03-04 20:21:40 PST
Created attachment 247925 [details]
Patch v1
Comment 2 David Kilzer (:ddkilzer) 2015-03-04 20:22:32 PST
(In reply to comment #0)
> Will follow up with Alexey in person.

Oops, didn't do this yet.  Review may have to wait.
Comment 3 Alex Christensen 2015-03-04 20:30:58 PST
Comment on attachment 247925 [details]
Patch v1

View in context: https://bugs.webkit.org/attachment.cgi?id=247925&action=review

> Source/WebCore/ChangeLog:1
>  2015-03-04  David Kilzer  <ddkilzer@apple.com>

The commit queue won't like that your name is at the bottom.  Land this manually.
Comment 4 Alex Christensen 2015-03-04 20:33:01 PST
I like it as-is, but talk to Alexey in person before landing.
Comment 5 David Kilzer (:ddkilzer) 2015-03-05 00:05:19 PST
(In reply to comment #3)
> Comment on attachment 247925 [details]
> Patch v1
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=247925&action=review
> 
> > Source/WebCore/ChangeLog:1
> >  2015-03-04  David Kilzer  <ddkilzer@apple.com>
> 
> The commit queue won't like that your name is at the bottom.  Land this
> manually.

We need a bug about this if the commit queue fails on a patch like this.  It should apply cleanly as I wrote the code in svn-apply that fixes this up!

<http://trac.webkit.org/browser/trunk/Tools/Scripts/VCSUtils.pm?annotate=blame#L1583>
Comment 6 David Kilzer (:ddkilzer) 2015-03-05 00:08:51 PST
(In reply to comment #5)
> (In reply to comment #3)
> > Comment on attachment 247925 [details]
> > Patch v1
> > 
> > View in context:
> > https://bugs.webkit.org/attachment.cgi?id=247925&action=review
> > 
> > > Source/WebCore/ChangeLog:1
> > >  2015-03-04  David Kilzer  <ddkilzer@apple.com>
> > 
> > The commit queue won't like that your name is at the bottom.  Land this
> > manually.
> 
> We need a bug about this if the commit queue fails on a patch like this.  It
> should apply cleanly as I wrote the code in svn-apply that fixes this up!
> 
> <http://trac.webkit.org/browser/trunk/Tools/Scripts/VCSUtils.
> pm?annotate=blame#L1583>

Original commit:  <http://trac.webkit.org/changeset/15393>
Comment 7 WebKit Commit Bot 2015-03-06 01:16:45 PST
Comment on attachment 247925 [details]
Patch v1

Clearing flags on attachment: 247925

Committed r181142: <http://trac.webkit.org/changeset/181142>
Comment 8 WebKit Commit Bot 2015-03-06 01:16:50 PST
All reviewed patches have been landed.  Closing bug.