Bug 129755

Summary: More FTL ARM fixes
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, commit-queue, ggaren, mark.lam, mhahnenberg, mmirman, msaboff, nrotem, oliver, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 112840    
Attachments:
Description Flags
the patch ggaren: review+

Description Filip Pizlo 2014-03-05 13:31:26 PST
Patch forthcoming.
Comment 1 Filip Pizlo 2014-03-05 13:33:41 PST
Created attachment 225908 [details]
the patch
Comment 2 WebKit Commit Bot 2014-03-05 13:36:23 PST
Attachment 225908 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/ftl/FTLDataSection.h:39:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 13 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Geoffrey Garen 2014-03-05 13:40:47 PST
Comment on attachment 225908 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=225908&action=review

r=me

> Source/JavaScriptCore/ChangeLog:11
> +        - Temporarily switch to allocating all MCJIT memory in the executable pool on non-x86
> +          platforms.

Can you file a bug about undoing this?

> Source/JavaScriptCore/ftl/FTLDataSection.h:39
> +    DataSection(VM&, CodeBlock*, size_t size, unsigned alignment);

Nix "size", please.
Comment 4 Filip Pizlo 2014-03-05 13:46:38 PST
(In reply to comment #3)
> (From update of attachment 225908 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=225908&action=review
> 
> r=me
> 
> > Source/JavaScriptCore/ChangeLog:11
> > +        - Temporarily switch to allocating all MCJIT memory in the executable pool on non-x86
> > +          platforms.
> 
> Can you file a bug about undoing this?

https://bugs.webkit.org/show_bug.cgi?id=129756

I added a fixme that references it also.

> 
> > Source/JavaScriptCore/ftl/FTLDataSection.h:39
> > +    DataSection(VM&, CodeBlock*, size_t size, unsigned alignment);
> 
> Nix "size", please.
Comment 5 Filip Pizlo 2014-03-05 13:56:41 PST
Landed in http://trac.webkit.org/changeset/165129