Bug 121087

Summary: toFooElement() should use static_cast, not reinterpret_cast.
Product: WebKit Reporter: Andreas Kling <kling>
Component: DOMAssignee: Andreas Kling <kling>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, buildbot, cdumez, commit-queue, eflews.bot, gyuyoung.kim, gyuyoung.kim, kling, philn, rniwa, webkit-ews, xan.lopez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 121080    
Attachments:
Description Flags
Patch
koivisto: review+, webkit-ews: commit-queue-
Patch none

Andreas Kling
Reported 2013-09-10 01:39:19 PDT
Have patch.
Attachments
Patch (36.26 KB, patch)
2013-09-10 01:43 PDT, Andreas Kling
koivisto: review+
webkit-ews: commit-queue-
Patch (37.58 KB, patch)
2013-09-10 02:02 PDT, Andreas Kling
no flags
Andreas Kling
Comment 1 2013-09-10 01:43:14 PDT
Created attachment 211184 [details] Patch Didn't actually try to build this yet. Let's see how it goes..
Antti Koivisto
Comment 2 2013-09-10 01:50:25 PDT
Comment on attachment 211184 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=211184&action=review > Source/WebCore/ChangeLog:19 > + - void toFooElement(constNode*) missing space > Source/WebCore/dom/Node.h:786 > +void to##NodeSubclassName(const NodeSubclassName*); \ > +void to##NodeSubclassName(const NodeSubclassName&); > + Anders suggested to use WTF_DELETE_FUNCTION. Does that not work?
Early Warning System Bot
Comment 3 2013-09-10 01:52:17 PDT
Early Warning System Bot
Comment 4 2013-09-10 01:54:58 PDT
Andreas Kling
Comment 5 2013-09-10 02:02:26 PDT
Antti Koivisto
Comment 6 2013-09-10 02:08:09 PDT
Comment on attachment 211184 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=211184&action=review > Source/WebCore/html/HTMLAnchorElement.h:158 > +NODE_TYPE_CASTS(HTMLAnchorElement) Since this only applies to Elements ELEMENT_TYPE_CASTS might be a better name.
Andreas Kling
Comment 7 2013-09-10 02:09:19 PDT
(In reply to comment #2) > (From update of attachment 211184 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=211184&action=review > > Source/WebCore/dom/Node.h:786 > > +void to##NodeSubclassName(const NodeSubclassName*); \ > > +void to##NodeSubclassName(const NodeSubclassName&); > > + > > Anders suggested to use WTF_DELETE_FUNCTION. Does that not work? Apparently not. It just says "no previous definition for toHurrElement()"
Build Bot
Comment 8 2013-09-10 02:20:45 PDT
WebKit Commit Bot
Comment 9 2013-09-10 02:40:06 PDT
Comment on attachment 211186 [details] Patch Clearing flags on attachment: 211186 Committed r155429: <http://trac.webkit.org/changeset/155429>
Build Bot
Comment 10 2013-09-10 02:40:08 PDT
EFL EWS Bot
Comment 11 2013-09-10 02:50:46 PDT
Lucas Forschler
Comment 12 2019-02-06 09:02:52 PST
Mass moving XML DOM bugs to the "DOM" Component.
Note You need to log in before you can comment on or make changes to this bug.