Bug 113915

Summary: Just linking LLVM into JSC causes all plugin tests to fail
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, barraclough, ggaren, mark.lam, mhahnenberg, msaboff, oliver, sam
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 112840    
Attachments:
Description Flags
the patch oliver: review+

Description Filip Pizlo 2013-04-03 18:38:03 PDT
I have no idea what is going on other than isolating it the patch that is just linking in LLVM.
Comment 1 Filip Pizlo 2013-04-03 18:38:42 PDT
<rdar://problem/13573903>
Comment 2 Filip Pizlo 2013-04-03 18:51:23 PDT
Tests skipped in http://trac.webkit.org/changeset/147604.
Comment 3 Filip Pizlo 2013-04-24 14:24:37 PDT
*** Bug 113914 has been marked as a duplicate of this bug. ***
Comment 4 Filip Pizlo 2013-08-29 15:42:03 PDT
This is because llvm always exports all of its symbols and also overrides raise/abort/__assert_rt.  The LLVM'ers will probably fix this eventually but we can work around it for now by doing our LLVM-for-WebKit builds with CPPFLAGS=-fvisibility=hidden.
Comment 5 Filip Pizlo 2013-08-29 15:49:24 PDT
Created attachment 210040 [details]
the patch

Note, that I plan to land this with new binary drops for Mountain Lion.  I assume r+ implies r+ for the binary drops.
Comment 6 Filip Pizlo 2013-08-29 20:29:47 PDT
Landed in http://trac.webkit.org/changeset/154867