Bug 108491

Summary: REGRESSION(r140201): It made 2 JSC test fail on ARM traditional
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Critical CC: fpizlo, gaborb, galpeter, loki, msaboff, ossy, rgabor, zherczeg
Priority: P1 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 108645, 79666, 107309    

Description Csaba Osztrogonác 2013-01-31 09:21:29 PST
After https://trac.webkit.org/changeset/140201 the following 
JSC tests started to fail on ARM traditional platform:
- ecma/Expressions/11.7.1.js
- ecma/Expressions/11.7.2.js

last good revision(r140200): http://build.webkit.sed.hu/builders/ARMv7%20Linux%20Qt5%20Release%20%28Test%29/builds/7798
first bad revision(r140201): http://build.webkit.sed.hu/builders/ARMv7%20Linux%20Qt5%20Release%20%28Test%29/builds/7797
Comment 1 Csaba Osztrogonác 2013-02-01 04:45:01 PST
I tried Thumb2 too (with QtWebKit), but the results are chaotic:

- r140200 - 67 fails - http://build.webkit.sed.hu/builders/ARMv7%20Linux%20Qt5%20Release%20%28Test%29/builds/7807
- r140201 - 73 fails - http://build.webkit.sed.hu/builders/ARMv7%20Linux%20Qt5%20Release%20%28Test%29/builds/7808

But the list of the failing tests are very different.
Comment 2 Csaba Osztrogonác 2013-02-01 09:14:07 PST
(In reply to comment #1)
> I tried Thumb2 too (with QtWebKit), but the results are chaotic:
> 
> - r140200 - 67 fails - http://build.webkit.sed.hu/builders/ARMv7%20Linux%20Qt5%20Release%20%28Test%29/builds/7807
> - r140201 - 73 fails - http://build.webkit.sed.hu/builders/ARMv7%20Linux%20Qt5%20Release%20%28Test%29/builds/7808
> 
> But the list of the failing tests are very different.

Thumb2 failuress are unrelated to this bug and all JSC tests pass on Thumb2
if you revert 2 patches. See https://bugs.webkit.org/show_bug.cgi?id=108632#c1 for details.
Comment 3 Csaba Osztrogonác 2013-02-15 03:36:27 PST
Fixed by http://trac.webkit.org/changeset/142544

*** This bug has been marked as a duplicate of bug 109491 ***