Bug 106612

Summary: Layout Test fast/dom/HTMLTemplateElement/ownerDocument-adoptNode.html is flaky
Product: WebKit Reporter: Dimitri Glazkov (Google) <dglazkov>
Component: Tools / TestsAssignee: Adam Klein <adamk>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, adamk, cdumez, eric, gyuyoung.kim, naginenis, rafaelw, rakuco, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 103547    
Attachments:
Description Flags
Patch none

Description Dimitri Glazkov (Google) 2013-01-10 15:42:13 PST
The following layout test is flaky on Win.

fast/dom/HTMLTemplateElement/ownerDocument-adoptNode.html

Probable cause: unknown.

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#showExpectations=true&tests=fast%2Fdom%2FHTMLTemplateElement%2FownerDocument-adoptNode.html
Comment 1 Adam Klein 2013-01-10 16:21:58 PST
Likely easy to fix by waiting for the onload event on the iframe. I guess I shouldn't be surprised that srcdoc is async.
Comment 2 Rafael Weinstein 2013-01-14 17:44:48 PST
Note that efl port has also marked this as flaky (merging bug 106086 into this one).
Comment 3 Rafael Weinstein 2013-01-14 17:44:59 PST
*** Bug 106086 has been marked as a duplicate of this bug. ***
Comment 4 Adam Klein 2013-01-24 11:44:34 PST
Created attachment 184543 [details]
Patch
Comment 5 Eric Seidel (no email) 2013-01-24 12:05:16 PST
Comment on attachment 184543 [details]
Patch

OK.
Comment 6 WebKit Review Bot 2013-01-24 13:18:00 PST
Comment on attachment 184543 [details]
Patch

Clearing flags on attachment: 184543

Committed r140715: <http://trac.webkit.org/changeset/140715>
Comment 7 WebKit Review Bot 2013-01-24 13:18:05 PST
All reviewed patches have been landed.  Closing bug.