Bug 106086 - [EFL] Newly added layout test fast/dom/HTMLTemplateElement/ownerDocument-adoptNode.html is failing
Summary: [EFL] Newly added layout test fast/dom/HTMLTemplateElement/ownerDocument-adop...
Status: RESOLVED DUPLICATE of bug 106612
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-04 05:43 PST by Sudarsana Nagineni (babu)
Modified: 2013-01-14 17:44 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sudarsana Nagineni (babu) 2013-01-04 05:43:59 PST
Newly added layout test fast/dom/HTMLTemplateElement/ownerDocument-adoptNode.html is failing on EFL port after r138756.

http://build.webkit.org/results/EFL%20Linux%2064-bit%20Release%20WK2/r138790%20%282330%29/fast/dom/HTMLTemplateElement/ownerDocument-adoptNode-diff.txt

--- /home/buildslave-1/webkit-buildslave/efl-linux-64-release-wk2/build/layout-test-results/fast/dom/HTMLTemplateElement/ownerDocument-adoptNode-expected.txt
+++ /home/buildslave-1/webkit-buildslave/efl-linux-64-release-wk2/build/layout-test-results/fast/dom/HTMLTemplateElement/ownerDocument-adoptNode-actual.txt
@@ -1,17 +1,11 @@
+CONSOLE MESSAGE: line 1: TypeError: 'null' is not an object (evaluating 'frameTemplate.ownerDocument')
 Adopting a template from another document should also switch the template content document
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
 Before adoption:
-PASS template.ownerDocument is not frameTemplate.ownerDocument
-PASS template.content.ownerDocument is not frameTemplate.content.ownerDocument
-
-After adoption:
-PASS template.ownerDocument is frameTemplate.ownerDocument
-PASS template.content.ownerDocument is frameTemplate.content.ownerDocument
-
-PASS successfullyParsed is true
+FAIL successfullyParsed should be true (of type boolean). Was undefined (of type undefined).
 
 TEST COMPLETE
Comment 1 Rafael Weinstein 2013-01-14 17:44:59 PST

*** This bug has been marked as a duplicate of bug 106612 ***