Bug 106499

Summary: [QT][EFL][WK2] Rename scale members in PageViewportController.
Product: WebKit Reporter: Dongseong Hwang <dongseong.hwang>
Component: Layout and RenderingAssignee: Dongseong Hwang <dongseong.hwang>
Status: RESOLVED FIXED    
Severity: Normal CC: abecsi, benjamin, cmarcelo, gyuyoung.kim, kenneth, menard, rakuco, webkit-ews, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 106355    
Bug Blocks: 106504, 106512, 106537    
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Dongseong Hwang
Reported 2013-01-09 16:21:35 PST
Rename from m_contentsScale to m_pageScaleFactor and from devicePixelRatio() to deviceScaleFactor() to match terms of WebCore.
Attachments
Patch (9.94 KB, patch)
2013-01-09 16:22 PST, Dongseong Hwang
no flags
Patch (15.91 KB, patch)
2013-01-09 16:40 PST, Dongseong Hwang
no flags
Patch (9.85 KB, patch)
2013-01-09 16:44 PST, Dongseong Hwang
no flags
Dongseong Hwang
Comment 1 2013-01-09 16:22:53 PST
Early Warning System Bot
Comment 2 2013-01-09 16:33:17 PST
Dongseong Hwang
Comment 3 2013-01-09 16:40:17 PST
Dongseong Hwang
Comment 4 2013-01-09 16:44:44 PST
WebKit Review Bot
Comment 5 2013-01-09 19:12:57 PST
Comment on attachment 182014 [details] Patch Clearing flags on attachment: 182014 Committed r139274: <http://trac.webkit.org/changeset/139274>
WebKit Review Bot
Comment 6 2013-01-09 19:13:02 PST
All reviewed patches have been landed. Closing bug.
Benjamin Poulain
Comment 7 2013-01-09 19:19:26 PST
Comment on attachment 182014 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=182014&action=review > Source/WebKit2/UIProcess/PageViewportController.h:71 > float minimumContentsScale() const { return m_minimumScaleToFit; } > float maximumContentsScale() const { return m_rawAttributes.maximumScale; } > - float currentContentsScale() const { return m_contentsScale; } > + float currentContentsScale() const { return m_pageScaleFactor; } Wait what? Why do you keep names mixed here?
Dongseong Hwang
Comment 8 2013-01-09 19:42:37 PST
(In reply to comment #7) > (From update of attachment 182014 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=182014&action=review > > > Source/WebKit2/UIProcess/PageViewportController.h:71 > > float minimumContentsScale() const { return m_minimumScaleToFit; } > > float maximumContentsScale() const { return m_rawAttributes.maximumScale; } > > - float currentContentsScale() const { return m_contentsScale; } > > + float currentContentsScale() const { return m_pageScaleFactor; } > > Wait what? > Why do you keep names mixed here? Good point. Those methods are used by qt test code. I'll change xxxScale instead of xxxContentsScale.
Dongseong Hwang
Comment 9 2013-01-10 01:03:12 PST
(In reply to comment #7) > (From update of attachment 182014 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=182014&action=review > > > Source/WebKit2/UIProcess/PageViewportController.h:71 > > float minimumContentsScale() const { return m_minimumScaleToFit; } > > float maximumContentsScale() const { return m_rawAttributes.maximumScale; } > > - float currentContentsScale() const { return m_contentsScale; } > > + float currentContentsScale() const { return m_pageScaleFactor; } > > Wait what? > Why do you keep names mixed here? I fixed in Bug 106537.
Note You need to log in before you can comment on or make changes to this bug.