Bug 106408

Summary: Change semantics of subtracting one Int/FloatPoint from another
Product: WebKit Reporter: Steve Block <steveblock>
Component: New BugsAssignee: Steve Block <steveblock>
Status: RESOLVED WONTFIX    
Severity: Normal CC: aboxhall, andersca, apinheiro, cfleizach, cmarcelo, dino, dmazzoni, d-r, eric, fmalita, gyuyoung.kim, jamesr, jdiggs, junov, macpherson, menard, mifenton, noam, ojan.autocc, pdr, philn, rakuco, schenney, senorblanco, simon.fraser, steveblock, tkent, tonikitoo, webkit-ews, webkit.review.bot, xan.lopez, zeno
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Patch buildbot: commit-queue-

Steve Block
Reported 2013-01-08 19:37:33 PST
Change semantics of subtracting one Int/FloatPoint from another
Attachments
Patch (58.60 KB, patch)
2013-01-08 19:51 PST, Steve Block
no flags
Patch (64.94 KB, patch)
2013-01-08 22:07 PST, Steve Block
no flags
Patch (67.03 KB, patch)
2013-01-08 23:02 PST, Steve Block
no flags
Patch (68.94 KB, patch)
2013-01-09 16:10 PST, Steve Block
buildbot: commit-queue-
Steve Block
Comment 1 2013-01-08 19:51:06 PST
The common case of subtracting one Int/FloatPoint from another is to obtain a relative position or vector, so this should be supported by operator-(). Creating an Int/FloatSize from two Int/FloatPoints is a less common operation and should be made more explicit. I therefore propose that we ... - remove 'Int/FloatSize operator-(const int/FloatPoint&, const Int/FloatPoint&)' - add 'Int/FloatPoint operator-(const int/FloatPoint&, const Int/FloatPoint&)' - add 'Int/FloatSize Int/FloatSize::fromCornerPoints(const int/FloatPoint&, const Int/FloatPoint&)'
Steve Block
Comment 2 2013-01-08 19:51:19 PST
Steve Block
Comment 3 2013-01-08 19:55:37 PST
Patch for initial comments. A few things to note ... - Adding 'FloatPoint::distance(Squared)ToPoint(const FloatPoint&)' can be done in a prerequisite patch - https://bugs.webkit.org/show_bug.cgi?id=105995 - The XCode project file needs updating - I can move more implementation to the new IntSize.cpp I'll wait for initial feedback before addressing these things.
Early Warning System Bot
Comment 4 2013-01-08 20:01:32 PST
Early Warning System Bot
Comment 5 2013-01-08 20:04:57 PST
Build Bot
Comment 6 2013-01-08 20:24:13 PST
Build Bot
Comment 7 2013-01-08 20:38:28 PST
EFL EWS Bot
Comment 8 2013-01-08 21:57:14 PST
Steve Block
Comment 9 2013-01-08 22:07:07 PST
Early Warning System Bot
Comment 10 2013-01-08 22:24:33 PST
EFL EWS Bot
Comment 11 2013-01-08 23:00:28 PST
Steve Block
Comment 12 2013-01-08 23:02:23 PST
Build Bot
Comment 13 2013-01-09 00:09:43 PST
Build Bot
Comment 14 2013-01-09 01:08:17 PST
Steve Block
Comment 15 2013-01-09 16:10:17 PST
Build Bot
Comment 16 2013-01-09 17:22:35 PST
Steve Block
Comment 17 2013-01-09 18:14:57 PST
It seems there ins't the required level of support for this change. See http://lists.webkit.org/pipermail/webkit-dev/2013-January/023212.html
Note You need to log in before you can comment on or make changes to this bug.